xfs
[Top] [All Lists]

Re: Volume fine on x86_64, corruption on ARM

To: Brian Foster <bfoster@xxxxxxxxxx>
Subject: Re: Volume fine on x86_64, corruption on ARM
From: Lluís Batlle i Rossell <viric@xxxxxxxxxx>
Date: Mon, 4 Feb 2013 18:46:52 +0100
Cc: xfs@xxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <510EE8B2.6040301@xxxxxxxxxx>
References: <20130127225258.GA2287@xxxxxxxxxxxxxxxxxxxxxx> <510EE8B2.6040301@xxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Sun, Feb 03, 2013 at 05:46:10PM -0500, Brian Foster wrote:
> On 01/27/2013 05:52 PM, Lluís Batlle i Rossell wrote:
> > Hello,
> > 
> > I'm using linux 3.7.3 in both machines (x86_64 and armv5tel), and I created
> > a volume in x86_64 to be the rootfs for the ARM. All fine, until I plugged 
> > it
> > into the ARM (Log below).
> > 
> > Given the corruption, I used xfs_repair in the x86_64, moved a lot of files 
> > into lost+found, plugged it back to the ARM, booted, and corruption again.
> > 
> > In the same USB HD, in the same ARM, and this same way, I've used 
> > succesfully
> > ext4 and btrfs for a long time. Is there any known issue with ARM?
> > 
> 
> FYI, I played around with my old sheevaplug a bit and so far, only
> reproduced what I think are some USB (possibly hardware) issues. I
> started with a 3.8.0-rc6 kernel and an sdcard and was reproducing
> consistent USB resets leading to all sorts of errors.
> 
> I went back to 3.7.3 and replaced the sdcard with a thumb drive and
> reproduced corruption errors several times on a reboot (not on initial
> boot iirc). This required an fsck or reformat from my host system. I was
> also occasionally reproducing USB debounce errors that required me to
> power cycle and remove/attach the USB drive, which led me to try several
> boot attempts with a clean power cycle and attaching the USB drive after
> the bootloader (u-boot) has initialized, and with that sequence I
> couldn't reproduce the error.
> 
> Unfortunately, I then tried several soft reboot cycles with the drive
> attached and the error hasn't fired, so I can't make any serious
> conclusion from that other than the possibility of flaky drivers or
> hardware. Does your XFS rootfs _always_ fail, or can you get it to boot
> occasionally or with a power cycle? This, of course, could be completely
> unrelated to the issue you observe. I haven't tried a non-XFS filesystem
> yet on this drive either. I'll play with it more when I have some more time.

Sorry, I'm on a trip, and I can't test this soon.

I used the same USB HD with the same kernel very well, with reiserfs and btrfs,
for many months (running fine with previous kernels too).
I tried three times to boot with XFS, and the corruption came up before systemd
could start properly every time.

I switched to Ext4, and I've had no problem since then either. That's why I
concluded it was only XFS having the problem.

Thank you for your time!

<Prev in Thread] Current Thread [Next in Thread>