xfs
[Top] [All Lists]

Re: XFS appears to cause strange hang with md raid1 on reboot

To: Tom <storm9c1@xxxxxxxxxxxx>, xfs@xxxxxxxxxxx
Subject: Re: XFS appears to cause strange hang with md raid1 on reboot
From: Stefan Ring <stefanrin@xxxxxxxxx>
Date: Thu, 31 Jan 2013 08:35:52 +0100
Delivered-to: xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=mime-version:x-received:in-reply-to:references:date:message-id :subject:from:to:content-type; bh=Wdaefn6EQ2545PBJfQfmls8MocxPM1iVlErIT1WkR9A=; b=EasPjzQ/LOMlCKXSoSVyt+LeP0UNC0g9KWj5Xgavs5EqW7BWvDhnjVlCy4pwl6kAOE Ms6sQHAdptE2mTFczNtxaMeW9DleTlWmn3SFJK8CSrqL72nXqDgn6xhNk4mIVYLX/kvB VRj8uqFdzJbfVZTMNaaMmRcXImOxkd2dMmlFvMc00NQcUKMvogwuaUMfOkYbHHXTDZ15 aIrPlbnxvRGF+w2dT8OQ5ErLpeRa/Pwh0cQoAJGTLC1hZQEtt+Qg0cSzzkOqmDAOdq8I FCi9ccMnRK/I5HxYzbpttjR4WZL35OPrUcX4tW79cA+rMG+FBTFpkAV3IUg1ZvlyxW8V u0MA==
In-reply-to: <20130130234650.GE32297@xxxxxxxxxxxxxxxxxx>
References: <32271.192.104.24.222.1359415698.squirrel@xxxxxxxxxxxxxxxxxxx> <20130129151833.GF27055@xxxxxxx> <42720.75.149.17.233.1359515780.squirrel@xxxxxxxxxxxxxxxxxxx> <20130130234650.GE32297@xxxxxxxxxxxxxxxxxx>
> So the filesystems are unmounted....
>
> And this says the filesystem is still mounted. Why?

When I last had a problem with shutdown, it was because of mount
namespaces. You can unmount all day long, but as long as there is a
mount still open in a namespace, nothing will get unmounted. This was
on Fedora though; don't know if RHEL 5.x makes use of namespaces.

<Prev in Thread] Current Thread [Next in Thread>