xfs
[Top] [All Lists]

Re: Volume fine on x86_64, corruption on ARM

To: Lluís Batlle i Rossell <viric@xxxxxxxxxx>
Subject: Re: Volume fine on x86_64, corruption on ARM
From: Eric Sandeen <sandeen@xxxxxxxxxxx>
Date: Mon, 28 Jan 2013 16:45:10 -0600
Cc: xfs@xxxxxxxxxxx
Delivered-to: xfs@xxxxxxxxxxx
In-reply-to: <20130128224013.GK2287@xxxxxxxxxxxxxxxxxxxxxx>
References: <20130127225258.GA2287@xxxxxxxxxxxxxxxxxxxxxx> <5106FDA5.80409@xxxxxxxxxxx> <20130128224013.GK2287@xxxxxxxxxxxxxxxxxxxxxx>
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/20130107 Thunderbird/17.0.2
On 1/28/13 4:40 PM, Lluís Batlle i Rossell wrote:
> On Mon, Jan 28, 2013 at 04:37:25PM -0600, Eric Sandeen wrote:
>> So this was trying to read a dir2 directory metadata leaf block, and it 
>> didn't find the right magic.
>> XFSB is superblock magic . . . 
>>
>> I tested an image which (I think) contains every dir2 format, created on 
>> x86_64
>> (under a RHEL6 3.2 kernel) and checked it on ARM (a raspberry pi 3.2.24 
>> kernel)
>> so it's not really quite an apples to apples test.
>>
>> Does the filesystem check clean on x86_64 right after you create it?  How 
>> did you
>> create it?
> 
> Thank you for testing! You mean that your test went fine, right?

with the simple test on the above machines, yes, it was fine.

> I run:
> mkfs.xfs /dev/sdb1
> 
> Then I copied files to it. 

On the x86_64 machine, right.  Just to be sure, can you do an xfs_repair
on x86_64 to be sure it's clean at this point?

> After the first crash in the arm, I used xfs_repair on the
> x86_64. It created many lost+found. 

capturing the repair output here would be helpful.

> Then I tried again in the ARM, and it
> crashed again the same way.

And by "tried again" do you mean you booted from that filesystem on
the arm box, I guess, and then encountered the corruption?

-Eric

<Prev in Thread] Current Thread [Next in Thread>