xfs
[Top] [All Lists]

Re: xfsdump INTERRUPT issue

To: "J. Ellis" <jellis@xxxxxxxx>
Subject: Re: xfsdump INTERRUPT issue
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Wed, 19 Dec 2012 08:44:26 +1100
Cc: stan@xxxxxxxxxxxxxxxxx, "xfs@xxxxxxxxxxx" <xfs@xxxxxxxxxxx>
In-reply-to: <CCF63FDD.B0AC4%jellis@xxxxxxxx>
References: <50BAB19F.1010808@xxxxxxxxxxxxxxxxx> <CCF63FDD.B0AC4%jellis@xxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Tue, Dec 18, 2012 at 03:44:29PM -0500, J. Ellis wrote:
> Since it's been a few days since my last post, I'm going to basically start
> from scratch.
> 
> I'm running the following commands under Ubuntu 12.10:
> 
> mkdir /mnt/fp
> mkdir /mnt/hr20
> mount -t xfs -o rtdev=/dev/sda3 /dev/sda2 /mnt/fp
> mount -t xfs -o rdev=/dev/sdb3 /dev/sdb2 /mnt/hr20
> xfsdump -J - /mnt/hr20 | xfsrestore -J - /mnt/fp
> 
> When run, I get this as my output:
> 
> xfsdump: WARNING: write to stdio failed: 32 (Broken pipe)
> xfsdump: ending media file
> xfsdump: media file size 18874368 bytes
> xfsdump: dump size (non-dir files) : 13698056 bytes
> xfsdump: NOTE: dump interrupted: 16 seconds elapsed
> xfsdump: Dump Status: INTERRUPT
> 
> This happens each time. In te forum where this copy procedure was
> suggested, they've been reporting that the latest xfsprogs is creating these
> errors, which didn't happen under at least somewhat earlier versions.
> 
> I tried dumping to a file and then restoring from the file to the fp volume
> by using these commands:
> 
> mount -t xfs -o rtdev=/dev/sda3 /dev/sda2 /mnt/fp
> mount -t xfs -o rtdev=/dev/sdb3 /dev/sdb2 /mnt/hr20
> xfsdump -J -f /Desktop/xfsdump_hr20 /mnt/hr20
> xfsrestore -J -f /Desktop/xfsdump_hr20 /mnt/p
> 
> When this is tried, the process starts, but never completes. After 4 hours
> it reported 0.0% complete. So it was stopped.

What is the output?

> kernel version: Linux jeffrey 3.5.0-18-generic #29-Ubuntu SMP Fri Oct 19
> 10:27:31 UTC 2012 i686 i686 i686 GNU/Linux

It's a 32 bit kernel. Interesting.

> xfsprogs version: xfs_repar version 3.1.8
> 
> number of CPU's: 8

SMP, and:

> contents of /proc/meminfo:
> MemTotal:        6184324 kB
> MemFree:         4986560 kB

PAE enabled, by the look of it.

Any reason for running a 32 bit kernel on this hardware and not a 64
bit (x86_64) kernel?

> dmesg output
....
> [  295.334213] SGI XFS with ACLs, security attributes, realtime, large 
> block/inode numbers, no debug enabled
> [  295.389636] XFS (sda2): Mounting Filesystem
> [  295.459074] XFS (sda2): Ending clean mount
> [  299.575714] [Hardware Error]: Machine check events logged

There's something going wrong with your hardware, it appears. This
may or may not be related to the xfsdump problem, but you should
find out what these errors are.

Other than that, I need to see the complete output of xfsdump up to
the point it is apparently hanging. When you think it has hung, can
you provide the output of `iostat -d -x -m 5` for a period of about
a minute to see if there is disk IO taking place? it would also be
handy to know if there is any cpu being used at the same time...

A snaphost of /proc/meminfo when you consider it hung would also be
useful...

Cheers,

Dave.
-- 
Dave Chinner
david@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>