xfs
[Top] [All Lists]

Bug#695875: xfsprogs: Build-Depend on libreadline6 rather than libreadli

To: Debian Bug Tracking System <submit@xxxxxxxxxxxxxxx>
Subject: Bug#695875: xfsprogs: Build-Depend on libreadline6 rather than libreadline5
From: Nick Black <nick.black@xxxxxxxxxxxxxxx>
Date: Thu, 13 Dec 2012 16:27:30 -0500
Delivered-to: submit@xxxxxxxxxxxxxxx
Reply-to: Nick Black <nick.black@xxxxxxxxxxxxxxx>, 695875@xxxxxxxxxxxxxxx
Resent-cc: dank@xxxxxxxxx, XFS Development Team <xfs@xxxxxxxxxxx>
Resent-date: Thu, 13 Dec 2012 21:30:02 +0000
Resent-from: Nick Black <nick.black@xxxxxxxxxxxxxxx>
Resent-message-id: <handler.695875.B.135543404229083@xxxxxxxxxxxxxxx>
Resent-sender: Debian BTS <debbugs@xxxxxxxxxxxxxxxxxxxx>
Resent-to: debian-bugs-dist@xxxxxxxxxxxxxxxx
Package: xfsprogs
Version: 3.1.9
Severity: normal
Tags: patch

Dear Maintainer,

Hello! During development of SprezzOS, I noticed that the xfsprogs
package Build-Depends on

             libreadline-gplv2-dev | libreadline5-dev

libreadline5-dev no longer exists in the archive; the current
implementation is libreadline6-dev. Please make this change, so that
machines with libreadline6-dev installed can build the package.

-- System Information:
Debian Release: turing-β/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.7.0 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages xfsprogs depends on:
ii  libblkid1     2.22.1-SprezzOS3
ii  libc6         2.13-37
ii  libreadline5  5.2-12
ii  libuuid1      2.22.1-SprezzOS3

xfsprogs recommends no packages.

Versions of packages xfsprogs suggests:
ii  acl      2.2.51-8
pn  attr     <none>
pn  quota    <none>
pn  xfsdump  <none>

-- no debconf information

<Prev in Thread] Current Thread [Next in Thread>