xfs
[Top] [All Lists]

Re: Bug#695640: xfs_quota: cannot find mount point for path: Success

To: Alex Elder <elder@xxxxxxxxxxx>
Subject: Re: Bug#695640: xfs_quota: cannot find mount point for path: Success
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Wed, 12 Dec 2012 11:14:25 +1100
Cc: xfs@xxxxxxxxxxx
In-reply-to: <50C7C40D.8070002@xxxxxxxxxxx>
References: <CAA0ZO6CtLRkgrpXqapg3B5oMwGdLq8tS3y4dYG47aYX5BZkA=g@xxxxxxxxxxxxxx> <20121211221419.GZ27055@xxxxxxx> <CAA0ZO6APzwQCX=yf=qq8NkmjwDHVsgRBNCgN3KNW3RLgAWB=8A@xxxxxxxxxxxxxx> <20121211223700.GA27055@xxxxxxx> <CAA0ZO6BOUXTMpdrR-r=__-ZaAM6X39h2SisYXLfTTraTcttr+g@xxxxxxxxxxxxxx> <20121211231533.GG16353@dastard> <CAA0ZO6BvLQGt_9G-FSi+ZMCzJh_kmb1z2bdoPPwaVMVVK1UXJw@xxxxxxxxxxxxxx> <50C7C40D.8070002@xxxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Tue, Dec 11, 2012 at 05:38:53PM -0600, Alex Elder wrote:
> On 12/11/2012 05:20 PM, Brian May wrote:
> > On 12 December 2012 10:15, Dave Chinner <david@xxxxxxxxxxxxx> wrote:
> > 
> >> Full strace output, please.
> > 
> > 
> > Attached.

I haven't got the email yet, but I've looked at it in the
archives...

What's the contents of /proc/self/mounts?

> fs_mount_point_from_path() probably needs to set errno to ENOENT or
> something when the dir provided isn't in whatever "fs_cursor" is
> traversing (tree?).

The error is coming from setting up the project paths in the
table. It appears to be issuing the error when it cannot find the
XFs filesystem that the project is mounted on.

Can you run the command:

$ ~brian/xfsprogs/quota/xfs_quota  -x -c "path" -c "quota -N -u brian" -c 
"path" /home

An post the output so we can see the contents of the path table that
is being traversed?

Cheers,

Dave.
-- 
Dave Chinner
david@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>