xfs
[Top] [All Lists]

Re: How to run xfstests against multipath disks on SuSE?

To: "Theodore Ts'o" <tytso@xxxxxxx>
Subject: Re: How to run xfstests against multipath disks on SuSE?
From: Ryan Wang <openspace.wang@xxxxxxxxx>
Date: Tue, 27 Nov 2012 09:20:47 +0800
Cc: Lukáš Czerner <lczerner@xxxxxxxxxx>, linux-ext4@xxxxxxxxxxxxxxx, xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; bh=XPmILnFoWbnRgbRpVBu2HK0r8JqDYN+C+dpj+1vENhg=; b=DL09Rhb4Tms+oG1PBX6lAqygwHVcCO4noEXX0BjzimRLtHtksS/yOM29Um1dt6DRXC +hyNVW5UJ4b/G/8Nnn8nIDCsPkXhQfKY6qw3n9TCD6d6tb/fV79AY+tWXoZfyYbS9Z9J iAa7SZHDub0/RO1xxbT62HPym5SOlXlZBfLjBeFCvUlHIAFZ0pbhsDMO+BpkPGPTWDRl XdGQYNtPYqwlf+gw8jLjBVojI7eMJNZiyMmvnr3m+RTOOnov+IVH4nDVnkD+nfpHAXGn WZ81B96Cs/gef2XG0xBNHl/ldM3QXivWrOIrAIXcpVxc0CXrZeaKi1tGxEewNB2aLmFX QBdA==
In-reply-to: <20121126145559.GK31891@xxxxxxxxx>
References: <CAPxxNQmwX+TmJ=B-H0f+bzpx5JdijyyRrxCAAZRi9+c8HjQL9Q@xxxxxxxxxxxxxx> <alpine.LFD.2.00.1211261442490.18234@localhost> <20121126145559.GK31891@xxxxxxxxx>
2012/11/26 Theodore Ts'o <tytso@xxxxxxx>:
> On Mon, Nov 26, 2012 at 02:43:40PM +0100, Lukáš Czerner wrote:
>> > The I checked the script common.rc, and found that it uses
>> > df to determine the filesystem type and it uses the realpath
>> > "/dev/dm-0" instead of "/dev/mapper/mpatha", while df always
>> > shows "devtmpfs" instead of "ext4" for /dev/dm-0.
>> >
>> > I run "mount" and found that devtmpfs is mount on /dev/ on opensuse
>> > ***by default***. Even though  I run "mount -t btrfs /dev/dm-0 /somedir",
>> > df still showed devtmpfs.
>> >
>> > Any ideas to kick off the xfstests?
>
> At least with the df which ships with Debian Testing, df will display
> the file system in use if it matches the device name which is
> /etc/mtab.  It looks the issue is that mount is canonicalizing the
> device name to be the human friendly version:
>
> # ls -l /dev/mapper/closure-bigscratch
> 0 lrwxrwxrwx 1 root root 7 Nov 16 15:15 /dev/mapper/closure-bigscratch -> 
> ../dm-7
> <tytso.root@closure> {/home/tytso/bin}, level 2
> # mount /dev/dm-7 /u2
> # df /u2
> Filesystem                     1K-blocks   Used Available Use% Mounted on
> /dev/mapper/closure-bigscratch  52403200 224772  52178428   1% /u2
> # grep /u2 /etc/mtab
> /dev/mapper/closure-bigscratch /u2 xfs rw,relatime,attr2,inode64,noquota 0 0
>
> So the simplest solution is to just use /dev/mapper/mpatha instead of
> insisting on using /dev/dm-0.  That's what I do....

In xfstests/common.rc, it will use realpath to obtain /dev/dm-0, even if you
specified /dev/mapper/mpatha.
My problem is in SuSE, the devtmpfs is mounted on /dev by default, seems
used by udev. And df reports devtmpfs on /dev/dm-0, instead of ext4.

>
>                                                 - Ted
>

<Prev in Thread] Current Thread [Next in Thread>