xfs
[Top] [All Lists]

Re: How to run xfstests against multipath disks on SuSE?

To: Lukáš Czerner <lczerner@xxxxxxxxxx>
Subject: Re: How to run xfstests against multipath disks on SuSE?
From: "Theodore Ts'o" <tytso@xxxxxxx>
Date: Mon, 26 Nov 2012 09:55:59 -0500
Cc: Ryan Wang <openspace.wang@xxxxxxxxx>, linux-ext4@xxxxxxxxxxxxxxx, xfs@xxxxxxxxxxx
In-reply-to: <alpine.LFD.2.00.1211261442490.18234@localhost>
References: <CAPxxNQmwX+TmJ=B-H0f+bzpx5JdijyyRrxCAAZRi9+c8HjQL9Q@xxxxxxxxxxxxxx> <alpine.LFD.2.00.1211261442490.18234@localhost>
User-agent: Mutt/1.5.21 (2010-09-15)
On Mon, Nov 26, 2012 at 02:43:40PM +0100, Lukáš Czerner wrote:
> > The I checked the script common.rc, and found that it uses
> > df to determine the filesystem type and it uses the realpath
> > "/dev/dm-0" instead of "/dev/mapper/mpatha", while df always
> > shows "devtmpfs" instead of "ext4" for /dev/dm-0.
> > 
> > I run "mount" and found that devtmpfs is mount on /dev/ on opensuse
> > ***by default***. Even though  I run "mount -t btrfs /dev/dm-0 /somedir",
> > df still showed devtmpfs.
> > 
> > Any ideas to kick off the xfstests?

At least with the df which ships with Debian Testing, df will display
the file system in use if it matches the device name which is
/etc/mtab.  It looks the issue is that mount is canonicalizing the
device name to be the human friendly version:

# ls -l /dev/mapper/closure-bigscratch 
0 lrwxrwxrwx 1 root root 7 Nov 16 15:15 /dev/mapper/closure-bigscratch -> 
../dm-7
<tytso.root@closure> {/home/tytso/bin}, level 2  
# mount /dev/dm-7 /u2
# df /u2
Filesystem                     1K-blocks   Used Available Use% Mounted on
/dev/mapper/closure-bigscratch  52403200 224772  52178428   1% /u2
# grep /u2 /etc/mtab
/dev/mapper/closure-bigscratch /u2 xfs rw,relatime,attr2,inode64,noquota 0 0

So the simplest solution is to just use /dev/mapper/mpatha instead of
insisting on using /dev/dm-0.  That's what I do....

                                                - Ted

<Prev in Thread] Current Thread [Next in Thread>