xfs
[Top] [All Lists]

Re: Problems with kernel 3.6.x (vm ?) (was : Is kernel 3.6.1 or filestre

To: xfs@xxxxxxxxxxx
Subject: Re: Problems with kernel 3.6.x (vm ?) (was : Is kernel 3.6.1 or filestreams option toxic ?)
From: Yann Dupont <Yann.Dupont@xxxxxxxxxxxxxx>
Date: Sat, 27 Oct 2012 00:05:34 +0200
In-reply-to: <508A600C.1020109@xxxxxxxxxxxxxx>
References: <508554AF.5050005@xxxxxxxxxxxxxx> <50865453.5080708@xxxxxxxxxxxxxx> <508958FF.4000007@xxxxxxxxxxxxxx> <20121025211047.GD29378@dastard> <508A600C.1020109@xxxxxxxxxxxxxx>
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20121017 Thunderbird/16.0.1
Le 26/10/2012 12:03, Yann Dupont a écrit :
Le 25/10/2012 23:10, Dave Chinner a écrit :

I'll try now to reproduce this kind of behaviour on a verry little volume (10 GB for exemple) so I can confirm or inform the given scenario .


This is reproductible. Here is how to do it :

- Started a 3.6.2 kernel.

- I created a fresh lvm volume on localdisk of 20 GB.
- mkfs.xfs on it, with default options
- mounted with default options
- launch something that hammers this volume. I launched compilebench 0.6 on it - wait some time to fill memory,buffers, and be sure your disks are really busy. I waited some minutes after the initial 30 kernel unpacking in compilebench - hard reset the server (I'm using the Idrac of the server to generate a power cycle) - After some try, I finally had the impossibility to mount the xfs volume, with the error reported in previous mails. So far this is normal .

xfs_logprint don't say much :

xfs_logprint:
    data device: 0xfe02
    log device: 0xfe02 daddr: 10485792 length: 20480

Header 0x7c wanted 0xfeedbabe
**********************************************************************
* ERROR: header cycle=124         block=5414 *
**********************************************************************

I tried xfs_logprint -c , it gaves a 22M file. You can grab it here :
http://filex.univ-nantes.fr/get?k=QnBXivz2J3LmzJ18uBV

- Rebooted 3.4.15
- xfs_logprint gives the exact same result that with 3.6.2 (diff tells no differences)

but on 3.4.15, I can mount the volume without problem, log is replayed.


for information here is xfs_info of the volume :

here is xfs_info output

root@label5:/mnt/debug# xfs_info /mnt/tempo
meta-data=/dev/mapper/LocalDisk-crashdisk isize=256 agcount=8, agsize=655360 blks
         =                       sectsz=512   attr=2
data     =                       bsize=4096   blocks=5242880, imaxpct=25
         =                       sunit=0      swidth=0 blks
naming   =version 2              bsize=4096   ascii-ci=0
log      =internal               bsize=4096   blocks=2560, version=2
         =                       sectsz=512   sunit=0 blks, lazy-count=1
realtime =none                   extsz=4096   blocks=0, rtextents=0


Does this helps you ?
Cheers,

--
Yann Dupont - Service IRTS, DSI Université de Nantes
Tel : 02.53.48.49.20 - Mail/Jabber : Yann.Dupont@xxxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>