xfs
[Top] [All Lists]

Enabling quota on XFS filesystem with many files hangs

To: xfs@xxxxxxxxxxx
Subject: Enabling quota on XFS filesystem with many files hangs
From: Milan Holzäpfel <listen@xxxxxxxx>
Date: Fri, 26 Oct 2012 19:15:40 +0200
Hello all, 

I have an XFS filesystem of size 1.2 TiB with 101 GiB free space and 14
million inodes in use. Quotas are disabled on the filesystem. I try to
enable user and group quotas by mounting with

mount /dev/xfs_device /mnt -o uquota,gquota

I first tried this with the 3.2.0 Kernel from Ubuntu 12.04 and hit an
OOM [1, 2]. In [1], it is said that the OOM is fixed in 3.5, so I tried
3.5.7 and 3.6.3 from http://kernel.ubuntu.com/~kernel-ppa/mainline/ (I
believe these are vanilla kernel.org kernels compiled with Ubuntu's
configuration). 

With 3.5.7 and 3.6.3, the OOM does not occur. For some time after
issuing the mount command, there is much I/O activity with xfs_inode
in /proc/slabinfo growing up to ~ 500k entries, which is just fine. At
some point, the I/O activity stops, but the mount does not terminate.
The system is completely idle. (The mount was the only activity on the
system.) 

In dmesg, I find

INFO: task mount:8806 blocked for more than 120 seconds.

in regular intervals. 

Can you help me with this? Thanks in advance. 

Regards,
Milan Holzäpfel



[1]: http://oss.sgi.com/archives/xfs/2012-06/msg00362.html
[2]: http://oss.sgi.com/archives/xfs/2012-09/msg00260.html



-- 
Milan Holzäpfel <listen@xxxxxxxx>

<Prev in Thread] Current Thread [Next in Thread>