xfs
[Top] [All Lists]

Re: [PATCH 02/10] xfstests: rename USE_BIG_LOOPFS to be more generic

To: Rich Johnston <rjohnston@xxxxxxx>
Subject: Re: [PATCH 02/10] xfstests: rename USE_BIG_LOOPFS to be more generic
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Sat, 1 Sep 2012 09:30:51 +1000
Cc: xfs@xxxxxxxxxxx
In-reply-to: <503CCF3F.5050608@xxxxxxx>
References: <1343291989-14987-1-git-send-email-david@xxxxxxxxxxxxx> <1343291989-14987-3-git-send-email-david@xxxxxxxxxxxxx> <503CCF3F.5050608@xxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Tue, Aug 28, 2012 at 09:01:35AM -0500, Rich Johnston wrote:
> On 07/26/2012 03:39 AM, Dave Chinner wrote:
> >From: Dave Chinner <dchinner@xxxxxxxxxx>
> >
> >USE_BIG_LOOPFS is really misnamed - it can be used on real devices just as
> >easily as loop devices. It really means we are testing a large scratch device
> >and that we should enable the special filesystem filling and checking options
> >that enable xfstests to be run sanely on large XFS filesystems.
> >
> >Signed-off-by: Dave Chinner <dchinner@xxxxxxxxxx>
> >---
> >  004       |    2 +-
> >  015       |    2 +-
> >  030       |    2 +-
> >  031       |    2 +-
> >  032       |    2 +-
> >  033       |    4 ++--
> >  041       |    2 +-
> >  049       |    2 +-
> >  083       |    2 +-
> >  092       |    2 +-
> >  148       |    2 +-
> >  149       |    2 +-
> >  common    |    2 +-
> >  common.rc |   12 ++++++------
> >  setup     |    5 +++--
> >  15 files changed, 23 insertions(+), 22 deletions(-)
> >
> 
> >  MOUNT_OPTIONS="$MOUNT_OPTIONS -o inode64"
> >  _scratch_mkfs_xfs | _filter_mkfs 2>/dev/null
> >diff --git a/148 b/148
> >index 76cbf37..7bb1722 100755
> >--- a/148
> >+++ b/148
> >@@ -66,8 +66,8 @@ _check_ag()
> >  _supported_fs xfs
> >  _supported_os IRIX Linux
> 
> #RCJ As long as you are making changes to this file, please remove
> Linux from the _supported_os as xfs_prepair64 is an IRIX specific
> binary.

Such a change belongs in a separate patch, not intermingled with a
patch in a series that has nothing to do with xfs_prepair64....

Cheers,

Dave.
-- 
Dave Chinner
david@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>