xfs
[Top] [All Lists]

XFS Mount Recovery Failed on Root File System After Power Outage

To: xfs@xxxxxxxxxxx
Subject: XFS Mount Recovery Failed on Root File System After Power Outage
From: Gim Leong Chin <chingimleong@xxxxxxxxxxxx>
Date: Thu, 30 Aug 2012 20:08:04 +0800 (SGT)
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=yahoo.com.sg; s=s1024; t=1346328484; bh=nY+sh8kOpgbtqft+mL9WE17DYoDsb/eWYQ39jewL4XU=; h=X-YMail-OSG:Received:X-Mailer:Message-ID:Date:From:Subject:To:MIME-Version:Content-Type:Content-Transfer-Encoding; b=CquaI3l2RTEql/sBsiNfvwqAblpopd5tgEBd/A2QaFmDmMjgNXmxGnKAzhlqcBKqWc49lZ5ubZFC5usg52DYD86Wp7aelYUo/t3Eo5rrXPe+AwMoZqwOZur1SLmH+QDByPkSfZhiV4uA52bsckuIsuuWt58VGfaeuZ3PNvCxJs8=
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com.sg; h=X-YMail-OSG:Received:X-Mailer:Message-ID:Date:From:Subject:To:MIME-Version:Content-Type:Content-Transfer-Encoding; b=G5CB4tnCu54uuGhFTqvEfLrVt1mmNG4plI+B9u4ICIek1oLsLBpBmPZ8Hi5wx7y7hlaqDDxBCdUaWG/kV5cw5iKFlOm8jjvFo+SZyQXTyP+Fh1sigRALLq8LZSnBat64cSApUt0bA5KLoqCwOvPUWDmn8Y9Up3ZBXukmkUxu4Oo=;
Hi


I just had a power outage and my Acer notebook computer running openSUSE 11.4 
x86_64 with kernel 2.6.37 stopped as a result.

After I reset the circuit breaker I was unable to boot the OS.

I booted up the openSUSE 11.4 rescue disk (installation media).  I ran the 
S.M.A.R.T. short self-test with smartctl on the W.D. Caviar Black 320 GB drive 
and there were no errors.  The S.M.A.R.T. parameters all look OK.  I have not 
run the long self test though.

I am able to mount the /home to /mnt on the rescue session and I see no error 
in /var/log/messages.

I then tried again to mount the root file system to /mnt.  

Aug 30 14:21:59 Rescue kernel: [  811.166914] XFS mounting filesystem sdb2
Aug 30 14:21:59 Rescue kernel: [  811.212169] Starting XFS recovery on 
filesystem: sdb2 (logdev: internal)
Aug 30 14:21:59 Rescue kernel: [  811.334157] XFS: Invalid block length 
(0xfffffffc) given for buffer
Aug 30 14:21:59 Rescue kernel: [  811.334175] XFS: log mount/recovery failed: 
error 117
Aug 30 14:21:59 Rescue kernel: [  811.334230] XFS: log mount failed

XFS Check will not run since log recovery mount has not been done.

What is the cause of the recovery failure and what is the recommended course of 
action?

The XFS Check and XFS Repair versions on the rescue disk are 3.1.4.  Are they 
sufficient to do any repair?

If I need a newer version of XFS Check and XFS Repair I will need to think of 
something since there is no compiler on the Rescue system and my openSUSE 11.4 
desktop is down with hardware failure.

Thank you for your assistance.



GL

<Prev in Thread] Current Thread [Next in Thread>