xfs
[Top] [All Lists]

XFS Mount Recovery Failed on Root File System After Power Outage

To: xfs@xxxxxxxxxxx
Subject: XFS Mount Recovery Failed on Root File System After Power Outage
From: "Chin Gim Leong" <CHIN_Gim_Leong@xxxxxxxxxxxxxxxxxxxxxxxxx>
Date: Thu, 30 Aug 2012 22:08:38 +0800
Importance: Normal
Sender: "Chin Gim Leong" <CHIN_Gim_Leong@xxxxxxxxxxxxxxxxxxxxxxxxx>
User-agent: SquirrelMail/1.4.19
Hi


I apologize first if this message appears a number of times, but my two
yahoo email accounts do not seem to be able to deliver to the mailing list
from afternoon till now and I have to use this account.

I just had a power outage and my Acer notebook computer running openSUSE
11.4 x86_64 with kernel 2.6.37 stopped as a result.

After I reset the circuit breaker I was unable to boot the OS.

I booted up the openSUSE 11.4 rescue disk (installation media).  I ran the
S.M.A.R.T. short self-test with smartctl on the W.D. Caviar Black 320 GB
drive and there were no errors.  The S.M.A.R.T. parameters all look OK.  I
have not run the long self test though.

I am able to mount the /home to /mnt on the rescue session and I see no
error in /var/log/messages.

I then tried again to mount the root file system to /mnt.

Aug 30 14:21:59 Rescue kernel: [  811.166914] XFS mounting filesystem sdb2
Aug 30 14:21:59 Rescue kernel: [  811.212169] Starting XFS recovery on
filesystem: sdb2 (logdev: internal)
Aug 30 14:21:59 Rescue kernel: [  811.334157] XFS: Invalid block length
(0xfffffffc) given for buffer
Aug 30 14:21:59 Rescue kernel: [  811.334175] XFS: log mount/recovery
failed: error 117
Aug 30 14:21:59 Rescue kernel: [  811.334230] XFS: log mount failed

XFS Check will not run since log recovery mount has not been done.

What is the cause of the recovery failure and what is the recommended
course of action?

I have tried the metadump and restore, then do a xfs_repair -L on the
metadump image, with xfs_repair version 3.1.8.  The repair is successful
and there are also some files copied to lost+found.

I would like to know the cause of this log recovery failure and if there
is another alternative to xfs_repair -L, since I do not really know what
files I would lose with the inodes being changed, and also I do not know
what the files in lost+found are.

Thank you for your assistance.



GL



<Prev in Thread] Current Thread [Next in Thread>