xfs
[Top] [All Lists]

xfs_repair - segemnation fault | git error

To: xfs@xxxxxxxxxxx
Subject: xfs_repair - segemnation fault | git error
From: Velimir Galic <veli.galic@xxxxxxxxx>
Date: Fri, 10 Aug 2012 10:23:03 +0200
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=mime-version:date:message-id:subject:from:to:content-type; bh=HW97aJwZ31LXroHGm/d02dJr6iNu1TQTKS3m/Q72yhY=; b=TYdZb5g5xNdtXHTybIApK+bT2pBC2bJwGSD8STzP/iUuzZI3ZgL6Id4bXBONGR+7Uw buJ1v4m66cQ6UCl2ValENeXbxC9cblB3MrGPgr4EbAb2AFOZLbfde6TxZnk4ywBagbm0 8vgYPNK40fftOFPYK/EaMH/sQGvLZEvVKIMrFglMfUwMc6XiqLb0eOxbZbfYj8Aj3KWt 5wKZDukWBwB198SGvnfX6mWzwcuAv8Da1aKldfXHq/S3eG1A4qdFwSi8ejZ43X92riuX FtCiSB0p3GBmmdalhlPWWfuV2i9UynfWyGfLrO/PVLq2jdWgxMOnHuTYb8lG/wCjx0OL Wu5Q==
hi Guys,

I hope you are able to help me, because i think that i tried everything that i know off to repair my raid after a disk failure.

Systemspecs:
  • HP N40L
    • CPU: AMD Turion II @ 1,5GHZ
    • 8GB ECC RAM
    • Disks:
      • 250GB | OS
      • 4x2GB | RAID 5 | Softraid
    • OS: Openmediavault @ 3.0.20 (last version)

Problem:

In my raid a disk was fault so mdadm kicked the disk out of the raid. I put a replacement in the box and started a resync of the raid and than is happened, a second disk got lost in the raid. The raidsync wasn't finished and now i'm fighting 3 weeks or more i don't no any more :-( to repair the file system. 

I tried a lot of different versions of xfs_repair (2.9.4, 2.9.8, 2.10.2, 3.0.4, 3.1.2, 3.1.6, 3.1,8), but every precompiled version got an "segmentation fault" or hung at phase 3 with 100% cpu load for few day. I also tried different distros like ubuntu, debian, redhat, gentoo (yes, i'm a little bit desperate :-) )  Than i tried the git version and at first it looked good but than i got an another error but i don't understand what the problem is.

tried options without any luck: xfs_repair -v -P | xfs_repair -v -P -m 6144 | xfs_repair -v -P -L 

Metadump of the filesystem isn't possible at this moment, but i could bootup a live cd and give it a try with it. I'm pretty stuck and don't no what to do any more.


with kind regards
Veli





Attachment: md127.metadump.err
Description: Binary data

<Prev in Thread] Current Thread [Next in Thread>