xfs
[Top] [All Lists]

Re: Repeated XFS corruption on RAID-10 on Adaptec 51245

To: "Christian J. Dietrich" <dietrich@xxxxxxxxxxxxxxxxxxxxxx>
Subject: Re: Repeated XFS corruption on RAID-10 on Adaptec 51245
From: Emmanuel Florac <eflorac@xxxxxxxxxxxxxx>
Date: Fri, 8 Jun 2012 12:51:38 +0200
Cc: xfs@xxxxxxxxxxx
In-reply-to: <4FD1C9B8.70907@xxxxxxxxxxxxxxxxxxxxxx>
Organization: Intellique
References: <4FD1C9B8.70907@xxxxxxxxxxxxxxxxxxxxxx>
Le Fri, 08 Jun 2012 11:45:28 +0200
"Christian J. Dietrich" <dietrich@xxxxxxxxxxxxxxxxxxxxxx> écrivait:

> I am running CentOS 6.2 (=RHEL 6.2) with kernel
> 2.6.32-220.17.1.el6.x86_64 (most recent) and all OS updates installed.
> Controller Firmware is the most recent (18948), driver version is
> 1.1-5. HDDs are 2x WD2001FASS, 10x WD2002FAEX.
> 

I currently manage many servers (about 50) with Adaptec 5xx5 raid
cards. The only case of data corruption I've met was with WD drives.

Therefore it's most probably related to the WD drives. WD desktop
drives are well known for being (voluntarily) crippled for RAID
operation. They will almost always create all sort of weird problems
when running under high IO load.

It is of utmost importance that you at least take care of setting TLER
in the correct mode on the drives. Beware that apparently newer WD
drives don't even allow setting TLER properly anymore (I said
"crippled").

http://en.wikipedia.org/wiki/Time-Limited_Error_Recovery


-- 
------------------------------------------------------------------------
Emmanuel Florac     |   Direction technique
                    |   Intellique
                    |   <eflorac@xxxxxxxxxxxxxx>
                    |   +33 1 78 94 84 02
------------------------------------------------------------------------

<Prev in Thread] Current Thread [Next in Thread>