[Top] [All Lists]

Re: [PATCH] Prefix IO_XX flags with XFS_IO_XX to avoid namespace colisio

To: xfs@xxxxxxxxxxx
Subject: Re: [PATCH] Prefix IO_XX flags with XFS_IO_XX to avoid namespace colision.
From: Alain Renaud <arenaud@xxxxxxx>
Date: Tue, 22 May 2012 19:35:54 -0400
In-reply-to: <20120522232424.GK25351@dastard>
References: <4fbbfd75.nYwhMRRjLSAq0x8u%arenaud@xxxxxxx> <20120522232424.GK25351@dastard>
User-agent: Mozilla/5.0 (X11; Linux i686; rv:12.0) Gecko/20120430 Thunderbird/12.0.1

On 12-05-22 07:24 PM, Dave Chinner wrote:
On Tue, May 22, 2012 at 03:56:21PM -0500, Alain Renaud wrote:
  This mod simply add a XFS_ prefix to IO_DIRECT,XFS_IO_DELALLOC,
XFS_IO_UNWRITTEN and XFS_IO_OVERWRITE. This to avoid namespace conflict
with other modules.
While I don't see any problems with making the change, I don't see
exactly how we could have a namespace clash here given they are
internal to XFS, not very widely included and have beenthis way for
years. What is the namespace clash you are seeing/caring about?



Hi Dave,

Looking at the XFS code in general we do tend to prefix XFS specific macro with XFS_ . I did hit the name conflict with one of our internal module I did fix our module to prefix with the module name but I thought since I did hit the problem that maybe other people might have the same issue. This is why I am proposing this mod. it is low priority but I find it is a little cleaner to have this prefix.

Hope this make sense.


Alain Renaud     - Cluster File System Engineer
arenaud@xxxxxxx  - SGI

<Prev in Thread] Current Thread [Next in Thread>