xfs
[Top] [All Lists]

Re: RAID5 created by 8 disks works with xfs

To: Jack Wang <jack.wang.usish@xxxxxxxxx>
Subject: Re: RAID5 created by 8 disks works with xfs
From: daobang wang <wangdb1981@xxxxxxxxx>
Date: Fri, 6 Apr 2012 14:49:59 +0800
Cc: stan@xxxxxxxxxxxxxxxxx, Marcus Sorensen <shadowsor@xxxxxxxxx>, Mathias Burén <mathias.buren@xxxxxxxxx>, linux-raid <linux-raid@xxxxxxxxxxxxxxx>, "xfs@xxxxxxxxxxx" <xfs@xxxxxxxxxxx>
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; bh=QBCYcRrgrVOAP3usC6ot/38X1uNwPhXTrB/qMfn5u14=; b=Uf6RwDYAkFEu+e7Hx1F+UqR2aNbw5btBct/Tqd059Btl+xei42Xv0umob4c/Rc0rSf 6B8jL1gLdZH4mbw9FEvo6ExpLBYudE+XLumpjOqBcwgJ8ob0rqNd3aoOffPjI9d8lU0i V+NerQtbIks7hS9GuYLeq+bBa2A+vGRDVQa8/POXkUXaF71Xr9pPBwkhwIzbPTxFrByS cbjhNr/Fx9z5efSU2C/vak2V6nm+/IqSxjav8rG4Mi4+0WWVY/ycF7qrLIt5d+zShWco Ltmu9W3zqFnsKWD9yv2ZzsMJUwSsELd3M0q8xRPxD7PEKYhIii8ZL/9NJ8F1sN1u3VAy ljMg==
In-reply-to: <CACwgYDN5ceD3ka-O9t1rGdj4tS=JpHVm_ZWetqZ7ZAOyEjqspA@xxxxxxxxxxxxxx>
References: <CACwgYDPQBNa7z7WcyUjV2Rx8Qf47r7eaRCowNKxjLBz+fYcfvQ@xxxxxxxxxxxxxx> <CADNH=7H_rgiY4fkB0SHo0yPhSBib7Gq-E_fu18yuJx=enn-eGg@xxxxxxxxxxxxxx> <4F776492.4070600@xxxxxxxxxxxxxxxxx> <CACwgYDOSrEYUps2VLpFSZ-irH7Mn_-BWrOYYDgXS=ULrmVuEPw@xxxxxxxxxxxxxx> <4F77D0B2.8000809@xxxxxxxxxxxxxxxxx> <CACwgYDMx6nQF-OwYj-BA+sZivUK=kmv2tPukgf5JGwA1vMTGrA@xxxxxxxxxxxxxx> <4F77EA55.6090004@xxxxxxxxxxxxxxxxx> <CACwgYDMVHT5DFjJztX9JvsVQJ+uOjPrfcs4+0aGXotDvf6tymQ@xxxxxxxxxxxxxx> <CACwgYDMXF9WEgzW9vL_0=GdRc_t+67WAkRTKNoKOMEMCvjujVw@xxxxxxxxxxxxxx> <CALFpzo5aKM2y_stDR14PNYMHEcq5CEptuFiXrvcCpXTzSQmAxw@xxxxxxxxxxxxxx> <4F792154.5020006@xxxxxxxxxxxxxxxxx> <CACwgYDPsZSEhuqNP8YgAksEq9BB6YOS1Q8jGx2J7DCrrOh_JQw@xxxxxxxxxxxxxx> <CACwgYDOtCoVF-p+KKqPYxHhA4vWF78Ueecx9hcVWLoyxFWzV9Q@xxxxxxxxxxxxxx> <4F7E0842.6090004@xxxxxxxxxxxxxxxxx> <CACwgYDMEpFqJhtUGeRg4hvux3GigNRnA--V18DwdyUvJpY434w@xxxxxxxxxxxxxx> <CACwgYDPur_8sO-BhhP-ggEmPCGa5ddsCcmSDfCuhD9OgiwGRyw@xxxxxxxxxxxxxx> <CA+res+RR5iAZsEY8G21YkQn+p_8EYSFvu4+H1SK=HXshOcS-4g@xxxxxxxxxxxxxx> <CACwgYDN5ceD3ka-O9t1rGdj4tS=JpHVm_ZWetqZ7ZAOyEjqspA@xxxxxxxxxxxxxx>
I did more tests, and found the mkfs.xfs did not hang.

I tried to make the xfs on 7TB logical volume, both 2.10.1 and 3.1.5
mkfs.xfs -f dev will work well, less than one minute.

But when i tried to make xfs on 8TB logical volume, 2.10.1 works well,
less than 1 minute, but 3.1.5 needs 5 minutes.

On 4/6/12, daobang wang <wangdb1981@xxxxxxxxx> wrote:
> Hi Jacky,
>
>      Yes, the environment is like your description, i will try with
> your suggestion. thanks a lot.
>
> On 4/6/12, Jack Wang <jack.wang.usish@xxxxxxxxx> wrote:
>> using bigger inode size or inode64 does help?
>>
>> So your environment is NVR software running in Linux ,100+ D1 streamer
>> directly write to filesystem on top of 16 SATA disks (with raid5 and
>> vg)?
>>
>> 2012/4/6 daobang wang <wangdb1981@xxxxxxxxx>:
>>> There is another issue, i updated xfsprog from 2.10.1 to 3.1.5, and
>>> found i could not make the xfs filesystem when the logical volume size
>>> large than 8TB with command mkfs.xfs -f -i size=512
>>> /dev/vg+vg00+20120406101850/lv+nxx+lv0000, this command seems hang, it
>>> did not return for a long time, is there any parameter i should
>>> adjust?
>>>
>>> Thank you very much
>>>
>>> Best Regards,
>>> Daobang Wang.
>>>
>>> On 4/6/12, daobang wang <wangdb1981@xxxxxxxxx> wrote:
>>>> Hi All,
>>>>
>>>>     I have found the solution, i updated the xfsprogs from 2.10.1 to
>>>> 3.1.5, and could repair it, Thanks.
>>>>
>>>> Best Wishes,
>>>> Daobang Wang.
>>>>
>>>> On 4/6/12, Stan Hoeppner <stan@xxxxxxxxxxxxxxxxx> wrote:
>>>>> On 4/5/2012 1:48 AM, daobang wang wrote:
>>>>>> Hi stan,
>>>>>>
>>>>>>      I duplicated the input/output error issue, about the detail
>>>>>> operations and logs, please see the attachments, Is there any way to
>>>>>> fix this? thanks!
>>>>>>
>>>>>> Best Regards,
>>>>>> Daobang Wang.
>>>>>
>>>>>
>>>>> These fiilesystem issues have nothing to do with linux-raid.  I'm
>>>>> copying the XFS mailing list which is where this discussion should be
>>>>> taking place from this point forward.  Please reply-to-all, and paste
>>>>> the output you previously attached, but inline this time.
>>>>>
>>>>> Also, since the XFS folks are unfamiliar with what you're doing up to
>>>>> this point, please provide a basic description of your
>>>>> hardware/storage
>>>>> setup, kernel version, mdraid configuration, xfs_info output as well
>>>>> as
>>>>> your fstab XFS mount options, and a description of your workload.
>>>>>
>>>>> My best guess at this point as to the du and ls errors is that your
>>>>> application is not behaving properly, or you're still running with XFS
>>>>> barriers disabled, which, I say _loudly_ for the 2nd time, you should
>>>>> NOT do in the absence of BBWC, which you stated you do not have.
>>>>>
>>>>> --
>>>>> Stan
>>>>>
>>>>
>>> --
>>> To unsubscribe from this list: send the line "unsubscribe linux-raid" in
>>> the body of a message to majordomo@xxxxxxxxxxxxxxx
>>> More majordomo info at  http://vger.kernel.org/majordomo-info.html
>>
>

<Prev in Thread] Current Thread [Next in Thread>