xfs
[Top] [All Lists]

Re: Placing the root partition on an XFS filesystem is not supported

To: Dave Chinner <david@xxxxxxxxxxxxx>
Subject: Re: Placing the root partition on an XFS filesystem is not supported
From: Eric Sandeen <sandeen@xxxxxxxxxxx>
Date: Sun, 05 Feb 2012 19:58:00 -0600
Cc: Marcos Mello <marcosfrm@xxxxxxxxx>, linux-xfs@xxxxxxxxxxx
In-reply-to: <20120206015430.GK6922@dastard>
References: <loom.20120129T133929-288@xxxxxxxxxxxxxx> <4F2B02C4.8070903@xxxxxxxxxxx> <loom.20120203T152753-631@xxxxxxxxxxxxxx> <4F2C2C69.5020103@xxxxxxxxxxx> <20120206001123.GJ6922@dastard> <4F2F1B28.3060308@xxxxxxxxxxx> <20120206015430.GK6922@dastard>
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0) Gecko/20120129 Thunderbird/10.0
On 2/5/12 7:54 PM, Dave Chinner wrote:
> On Sun, Feb 05, 2012 at 06:13:28PM -0600, Eric Sandeen wrote:
>> On 2/5/12 6:11 PM, Dave Chinner wrote:
>>> On Fri, Feb 03, 2012 at 12:50:17PM -0600, Eric Sandeen wrote:
>>>> On 2/3/12 8:39 AM, Marcos Mello wrote:
>>>>> Eric Sandeen <sandeen <at> sandeen.net> writes:
>>>>>
>>>>>>
>>>>>> In general there is no problem with xfs on a root partition.  However, 
>>>>>> the
>>>>> installer
>>>>>> may not make it easy or available for you.
>>>>>>
>>>>>> (I never use xfs for /boot though, I don't trust grub enough for that
>>>>> honestly).
>>>>>>
>>>>>> -Eric
>>>>>
>>>>> Same thing on Fedora 16. Let's hope some day Anaconda will change that.
>>>>
>>>> F16 prevents it?  I didn't see it in the upstream tree.  That should
>>>> not be so.  :/
>>>>
>>>>> About GRUB with a XFS /boot the problem was with GRUB Lagacy, wasn't it?
>>>>> Or GRUB2 is still buggy?
>>>>
>>>> I have no idea, actually.  I delved into grub a bit, it was disturbing
>>>> enough that I have not tried to look at grub2.  :)
>>>
>>> Certainly the problem exists with legacy grub - it assumes that it
>>> can write to the first sector or any disk or partition which
>>> overwrites the XFS superblock...
>>
>> well, it was worse than that.  I can work around the grub-on-a-partition
>> problem, but what I ran into was grub reading & writing to/from the block
>> device under a mounted filesystem - corruption and hilarity ensued.
> 
> Oh, grub2 does worse things than that - grub_probe mounts any device
> that appears to have a valid superblock so it can find out what
> devices it needs to list in it's boot menu. I found this out when I
> built a big DM stripe out of disks that used to have filesystems on
> them.  grub-probe mounted every single device -inside- the stripe
> and ran log recovery on them, corrupting the new filesystem and
> quite a bit of data on the DM stripe they were part of....

Ok, your horror story wins from a pain POV ;)

but sounds like someone should have zeroed out a bit more disk
when setting up the dm stripes :(

I've always thought maybe we needed a libzero.so to zap every known signature
on disk....

-Eric

> Cheers,
> 
> Dave.

<Prev in Thread] Current Thread [Next in Thread>