xfs
[Top] [All Lists]

Re: bug in fs/xfs/xfs_aops.c:959! (kernel 3.1.5)

To: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Subject: Re: bug in fs/xfs/xfs_aops.c:959! (kernel 3.1.5)
From: Jeremy Sanders <jeremy@xxxxxxxxxxxxxxxxx>
Date: Thu, 29 Dec 2011 11:07:17 +0000
Cc: linux-xfs@xxxxxxxxxxx
In-reply-to: <20111228171643.GA18895@xxxxxxxxxxxxx>
References: <jcn0ip$hsk$1@xxxxxxxxxxxxxxx> <20111228171643.GA18895@xxxxxxxxxxxxx>
User-agent: Mozilla/5.0 (X11; Linux i686; rv:8.0) Gecko/20111124 Thunderbird/8.0
On 28/12/11 17:16, Christoph Hellwig wrote:
Something must have set the page dirty without going through the normal
XFS codepath.  Did you use any interesting virtualization things, or
utrace / systemtap or anything odd?

This is plain hardware running a Fedora 16 standard x86-64 kernel. The hardware has been fine running F14 a long time for a few years, though I got the same error when I tried to run a rebuilt F15 kernel on F14 (2.6.38.8). See http://oss.sgi.com/archives/xfs/2011-07/msg00310.html

The problem happened very soon on upgrading from F14->F16.

Jeremy

<Prev in Thread] Current Thread [Next in Thread>