xfs
[Top] [All Lists]

Re: xfs_repair gets stuck on phase3

To: Pavol Zibrita <pavol.zibrita@xxxxxxxxx>
Subject: Re: xfs_repair gets stuck on phase3
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Mon, 12 Dec 2011 11:45:18 +1100
Cc: xfs@xxxxxxxxxxx
In-reply-to: <CAENWQX0FgOrTiDVaictZkNfnpBR40DWrHsWrysPHDvdoqvcw5A@xxxxxxxxxxxxxx>
References: <CAENWQX0FgOrTiDVaictZkNfnpBR40DWrHsWrysPHDvdoqvcw5A@xxxxxxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Sun, Dec 11, 2011 at 09:20:14PM +0000, Pavol Zibrita wrote:
> Hi there!
> 
>    After one hard reset, the xfs started to repair the partition and it
> wasn't able to end.
> (I let it running for two weeks...).
> 
> There was info about the log (and -L option), so the partition could not be
> mounted. I tried to do check and repair,
> but it was not working.
> 
> The setup is -> two radi5 raids, lvm, one volume group, one logical volume
> formated as xfs (4TB). Around
> 3,5TB full.
> 
> I tried various option for xfs_repair, but when in phase 3, it just
> calculates and calculates and does nothing.
> CPU is used around 97%.

It appears to be stuck processing an unlinked list (probably
circular due to corruption).

ISTR a patch recently to detect and handle this sort of loop.
Ah, in Christoph'sto-be-reivewed queue:

http://oss.sgi.com/archives/xfs/2011-12/msg00035.html

Specifically:

http://oss.sgi.com/archives/xfs/2011-12/msg00042.html

> Examining the system with knoppix live cd.

Which has what version of xfs_repair on it?

Cheers,

Dave.
-- 
Dave Chinner
david@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>