xfs
[Top] [All Lists]

xfs_repair gets stuck on phase3

To: xfs@xxxxxxxxxxx
Subject: xfs_repair gets stuck on phase3
From: Pavol Zibrita <pavol.zibrita@xxxxxxxxx>
Date: Sun, 11 Dec 2011 21:20:14 +0000
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; bh=JCM8wf6LLrXR5LfwAm31/pN2uUC9S8fTtdv7mPGFzxo=; b=cCf888EmTqJrIVzQhY6snZRFdUHX/XInAXAXBVac1JVhQ2wNFMGvNKRfCeiuQRBsGg b958R8Ne0/X6fzi4fx1EJCJmGhwCJuYN3lU6mq73v0yvc8yRl5SejtxsIEfkKgdK0oC6 61MnI2gGMfZlOeyWWhafYS0UaL4U2VWwIc3vA=
Hi there!

   After one hard reset, the xfs started to repair the partition and it wasn't able to end.
(I let it running for two weeks...).

There was info about the log (and -L option), so the partition could not be mounted. I tried to do check and repair,
but it was not working.

The setup is -> two radi5 raids, lvm, one volume group, one logical volume formated as xfs (4TB). Around
3,5TB full.

I tried various option for xfs_repair, but when in phase 3, it just calculates and calculates and does nothing.
CPU is used around 97%.

Examining the system with knoppix live cd.

Attaching logs with the outputs.
log.log: xfs_repair
p-log.log: with -P
strace-log.log stracing xfs_repair

After using the -L option I can mount the fs, but there are still bugs on the filesystem I would like to fix.

Currently, I don't have any other 4TB of space I could move the data to make some more drastic changes
like reformat or so.

Thanx for any advice!

Best regards,
Pavol Zibrita

Attachment: log.log
Description: Text Data

Attachment: p-log.log
Description: Text Data

Attachment: strace-log.log
Description: Text Data

<Prev in Thread] Current Thread [Next in Thread>