xfs
[Top] [All Lists]

Re: stale NFS file handle problem on XFS inode64

To: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Subject: Re: stale NFS file handle problem on XFS inode64
From: hank peng <pengxihan@xxxxxxxxx>
Date: Wed, 23 Nov 2011 09:19:26 +0800
Cc: linux-xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; bh=MBbbMCzAAskvGJXDZCEwCMpPcj2qLPWC73ZDA050Dvk=; b=PLyClXAlHjgo/S3rVCSM2badXjG6kwZQjdg8zgpX4MtArOt0ofLFTcSFBnLfKsMX0F DldrU9InJVEpe5lQY3eZTM33In4pFMU4r/suTN7BrjRaKSlrhSjcL6fsoEYOqqlDBtI2 YVv2+Kn8xVIq9zyrTjFNW/60Vt9YmEHB9ZfWk=
In-reply-to: <20111122221515.GA29540@xxxxxxxxxxxxx>
References: <CAJNJY8Q--O2Z3K6KFxVKOivwaABk+oRtC1y0eQ0nS1WdPNMwsQ@xxxxxxxxxxxxxx> <20111121170459.GA1327@xxxxxxxxxxxxx> <CAJNJY8Ty+bQpzGL9wq7Qv3ozcKUPwmTyYUeb2wQqZ326K4JeWw@xxxxxxxxxxxxxx> <20111122221515.GA29540@xxxxxxxxxxxxx>
2011/11/23 Christoph Hellwig <hch@xxxxxxxxxxxxx>:
> On Tue, Nov 22, 2011 at 08:19:15AM +0800, hank peng wrote:
>> > Do you export the root directory of the XFS filesystem, or a
>> > subdirectory in it? ??If it's the former it should work in theory,
>> > althrough I'm not sure how well 64-bit inode numbers work with a client
>> > that old, if it's the latter it needs a few tweaks to work, see
>> >
>> The following is what I did:
>> 1. mkfs.xfs /dev/sdb   (whole disk)
>> 2. create a mount point in my root filesystem:
>> mkdir /mnt/mymount
>> 3. monut xfs with inode64
>> mount /dev/sdb /mnt/mymount -o inode64
>> 4. export it in NFS /etc/exports
>> /mnt/mymount   *(rw, no_root,squash, sync)
>>
>> so, is there any problem here?
>
> That should work fine, and I've tried it a lot of times.  Do you see
> the same issue when mounting the fs on the server (not recommended for
> production use, just for testing!) and accessing it from the 2.6.35
> kernel nfs client?
>
yes, I have already done that. I mount the expoted NFS directory in
same machine(kernel version is 2.6.35.6), but it still didn't work.

Then, I used fsid=$(my exported filesystem ID) option in /etc/exports
and tried again, it still gave me back "stale NFS file handle" when
entering a specific subdirectory.
I noticed that from NFS client(in same machine with NFS server) side,
the inode number of this subdirectory was changed to be within 32
limit, but  still "stale NFS file handle" came back.

In local filesytem, I entered the mounted point and subdirectory, all is OK.

>



-- 
The simplest is not all best but the best is surely the simplest!

<Prev in Thread] Current Thread [Next in Thread>