[Top] [All Lists]

Re: [PATCH 7/9] xfs: clean up xfs_ioerror_alert

To: Dave Chinner <david@xxxxxxxxxxxxx>
Subject: Re: [PATCH 7/9] xfs: clean up xfs_ioerror_alert
From: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date: Fri, 7 Oct 2011 10:17:59 -0400
Cc: Christoph Hellwig <hch@xxxxxxxxxxxxx>, xfs@xxxxxxxxxxx
In-reply-to: <20111007015441.GD3159@dastard>
References: <20111006210607.175284390@xxxxxxxxxxxxxxxxxxxxxx> <20111006210639.731475087@xxxxxxxxxxxxxxxxxxxxxx> <20111007015441.GD3159@dastard>
User-agent: Mutt/1.5.21 (2010-09-15)
On Fri, Oct 07, 2011 at 12:54:41PM +1100, Dave Chinner wrote:
> Only thing I'm wondering about is whether is should be renamed
> xfs_buf_ioerror_alert(), now that it really is a xfs_buf specific
> function?

That probably is a better name.  There are a few other functions in the
buffer code that are misnamed like that e.g. xfs_incore and to a lesser
extent xfs_bwrite or XFS_bflush.

> Also, many of the callers could probably pass __func__ rather than a
> manually set string...


<Prev in Thread] Current Thread [Next in Thread>