xfs
[Top] [All Lists]

Re: [PATCH 7/9] xfs: clean up xfs_ioerror_alert

To: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Subject: Re: [PATCH 7/9] xfs: clean up xfs_ioerror_alert
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Fri, 7 Oct 2011 12:54:41 +1100
Cc: xfs@xxxxxxxxxxx
In-reply-to: <20111006210639.731475087@xxxxxxxxxxxxxxxxxxxxxx>
References: <20111006210607.175284390@xxxxxxxxxxxxxxxxxxxxxx> <20111006210639.731475087@xxxxxxxxxxxxxxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Thu, Oct 06, 2011 at 05:06:14PM -0400, Christoph Hellwig wrote:
> Instead of passing the block number and mount structure explicitly
> get them off the bp and fix make the argument order more natural.
> 
> Also move it to xfs_buf.c and stop printing the device name given
> that we already get the fs name as part of xfs_alert, and we know
> what device is operates on because of the caller that gets printed.
> 

Only thing I'm wondering about is whether is should be renamed
xfs_buf_ioerror_alert(), now that it really is a xfs_buf specific
function?

Also, many of the callers could probably pass __func__ rather than a
manually set string...

Otherwise, another nice cleanup.

Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx>

-- 
Dave Chinner
david@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>