xfs
[Top] [All Lists]

Re: xfs_repair segfaut in stage 6

To: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Subject: Re: xfs_repair segfaut in stage 6
From: Eric Sandeen <sandeen@xxxxxxxxxxx>
Date: Wed, 14 Sep 2011 09:57:09 -0500
Cc: Bartosz Cisek <bartosz.cisek@xxxxxxxxxxxxxx>, Michael Monnerie <michael.monnerie@xxxxxxxxxxxxxxxxxxx>, xfs@xxxxxxxxxxx
In-reply-to: <20110914142430.GA28049@xxxxxxxxxxxxx>
References: <4E69D1B9.8070201@xxxxxxxxxxxxxx> <201109091401.31422@xxxxxx> <4E6A2B73.50503@xxxxxxxxxxxxxx> <20110912161215.GA17798@xxxxxxxxxxxxx> <4E707624.9030703@xxxxxxxxxxxxxx> <20110914142430.GA28049@xxxxxxxxxxxxx>
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0.2) Gecko/20110902 Thunderbird/6.0.2
On 9/14/11 9:24 AM, Christoph Hellwig wrote:
> On Wed, Sep 14, 2011 at 11:38:44AM +0200, Bartosz Cisek wrote:
>> W dniu 12.09.2011 18:12, Christoph Hellwig pisze:
>>> I've repaired the image fine using xfs_repair from the Debian testing
>>> xfsprogs 3.1.5+nmu1 package.  It found two invalid blocks in a
>>> directory, which look like the result from the hardware error you saw.
>>>
>>> You should be able to just rebuild the current xfsprogs (from
>>> testing/unstable or git) on Lenny and get the same result.
>>
>> I've build xfs_repair from git on lenny and got segfault before my first
>> email to this list (please refer to first email in this thread) :)
> 
> Ooops.
> 
>> What else I can do to find what differ our two cases?
> 
> The hardware?  Given that you were getting read I/O errors from the
> hardware when shutting the fs down you probably got those as well when
> running repair and that caused the segfault.   Can you run xfs_repair
> under gdb for me, that is:
> 
> gdb /path/to.xfs_repair
> 
> (gdb) set args /dev/cciss/c0d5p1
> (gdb) run
> 
> and see what backtrace it gives you?
> 
> Please make sure to build xfs_repair in the git tree manually using
> make and not the Debian packaging, as that removes the debug symbols.
> 
> You can run gdb on the xfs_repair binary just built in the tree, no
> need to install it first.

If it worked for Christoph and not for Bartosz ....

Is the -DDEBUG / -DNDEBUG type setting the same in both cases?
Maybe Fedora is the only one doing -DNDEBUG :( but maybe worth
checking.

-Eric

> _______________________________________________
> xfs mailing list
> xfs@xxxxxxxxxxx
> http://oss.sgi.com/mailman/listinfo/xfs
> 

<Prev in Thread] Current Thread [Next in Thread>