On Wed, 2011-08-24 at 02:04 -0400, Christoph Hellwig wrote:
> plain text document attachment (xfs-bmapi-rename-xfs_bmapi)
> Once this is done, rename xfs_bmapi to xfs_bmapi_write to reflect the fact it
> is for allocation only. This enables us to kill the XFS_BMAPI_WRITE flag as
> Also clean up xfs_bmapi_write to the style used in the newly added
> xfs_bmapi_read/delay functions.
I have a few spelling corrections, otherwise this
is just beautiful.
Reviewed-by: Alex Elder <aelder@xxxxxxx>
. . .
> @@ -4806,60 +4805,57 @@ xfs_bmapi_convert_unwritten(
> - * Map file blocks to filesystem blocks.
> - * File range is given by the bno/len pair.
> - * Adds blocks to file if a write ("flags & XFS_BMAPI_WRITE" set)
> - * into a hole or past eof.
> - * Only allocates blocks from a single allocation group,
> - * to avoid locking problems.
> + * Map file blocks to filesystem blocks, and allocate blocks or convert the
> + * extent state if nessecary. Details behaviour is controlled by the flags
> + * paramter. Only allocates blocks from a single allocation group, to avoid
> + * locking problems.
> + *