xfs
[Top] [All Lists]

Re: [GIT PULL] XFS update for 3.1-rc4

To: Alex Elder <aelder@xxxxxxx>
Subject: Re: [GIT PULL] XFS update for 3.1-rc4
From: Linus Torvalds <torvalds@xxxxxxxxxxxxxxxxxxxx>
Date: Tue, 23 Aug 2011 11:46:30 -0700
Cc: linux-kernel@xxxxxxxxxxxxxxx, xfs@xxxxxxxxxxx, akpm@xxxxxxxxxxxxxxxxxxxx
In-reply-to: <201108231739.p7NHdXQ8008360@xxxxxxxxxxxxxxxxxxxxxx>
References: <201108231739.p7NHdXQ8008360@xxxxxxxxxxxxxxxxxxxxxx>
On Tue, Aug 23, 2011 at 10:39 AM, Alex Elder <aelder@xxxxxxx> wrote:
>
> Linus, please pull the following XFS changes.  Their effect is to
> remove the subdirectory structure from the XFS source hierarchy.
> There are no functional changes to the XFS code itself.  Thanks.

Pulled.

Any plans to further sanitize the namespace?

It's kind of crazy to have filenames like

   fs/xfs/xfs_trace.c

which just duplicate the "xfs" part for no good reason. Why not just
do something like

  for i in xfs_*; do j=$(echo $i | sed 's/^xfs_//'); git mv $i $j; done

to get rid of the silly "xfs_" prefix that adds nothing?

You could use the bytes you save to rename "qm.c" to "quota_manager.c"
instead. Wouldn't it be nice to have *good* names, instead of a jumble
of crazy and mostly redundant letters?

                        Linus

<Prev in Thread] Current Thread [Next in Thread>