xfs
[Top] [All Lists]

Re: "Corrupt dinode 6242615, (btree extents). This is a bug."<o

To: Michael Monnerie <michael.monnerie@xxxxxxxxxxxxxxxxxxx>
Subject: Re: "Corrupt dinode 6242615, (btree extents). This is a bug."<o
From: Hanne Munkholm <hanne@xxxxxxxxxx>
Date: Mon, 8 Aug 2011 14:53:57 +0200 (CEST)
Cc: xfs@xxxxxxxxxxx
In-reply-to: <201108081358.43727@xxxxxx>
References: <alpine.OSX.1.00.1108081203550.26464@xxxxxxxxxxxxxxxxxx> <201108081358.43727@xxxxxx>
User-agent: Alpine 1.00 (OSX 882 2007-12-20)
On Mon, 8 Aug 2011, Michael Monnerie wrote:
Yes, mount -L/umount once to replay the log, when you are sure the block
device works correctly again.

Thank you very much for your reply.

I don't see an -L option to the mount command meaning "replay
log", I think if I was able to mount it, it would replay the log
by itself? However, I cannot mount it.

<snip>

Try to get the newest xfsprogs, maybe that's a bug in xfs_repair itself
that has been fixed. If that doesn't help, a newer kernel might solve
your problem.

That is a good idea, I downloaded xfsprogs 3.1.5 but it gave the
same results. Provided that it's OK to run it from the folder I
compiled it and it is not using libraries from the old version
somehow.

Trying with a newer kernel is possible but some trouble, is it
likely to help?

If I run an xfs_repair, will it get me anywhere even if it
segfaults at the same point?

Do you recommend that I run an xfs_repair with or without -L, or
should I definetly try a new kernel first?


Med venlig hilsen / Best regards
--
Hanne Munkholm                      Email: hanne@xxxxxxxxxx
Systemadministrator                 Tlf: +45 35 32 13 49

Bioinformatik-centret
Københavns Biocenter, Biologisk Institut
Ole Maaløes Vej 5, 2200 København N

<Prev in Thread] Current Thread [Next in Thread>