xfs
[Top] [All Lists]

Re: xfs compile error with the latest -git

To: Francesco Allertsen <fallertsen@xxxxxxxxx>
Subject: Re: xfs compile error with the latest -git
From: Markus Trippelsdorf <markus@xxxxxxxxxxxxxxx>
Date: Wed, 27 Jul 2011 08:35:59 +0200
Cc: Alex Elder <aelder@xxxxxxx>, xfs-masters@xxxxxxxxxxx, Christoph Hellwig <hch@xxxxxx>, Al Viro <viro@xxxxxxxxxxxxxxxxxx>, Dave Chinner <dchinner@xxxxxxxxxx>, xfs@xxxxxxxxxxx, linux-kernel@xxxxxxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=simple; d=mail.ud10.udmedia.de; h= date:from:to:cc:subject:message-id:references:mime-version: content-type:in-reply-to; q=dns/txt; s=beta; bh=IhYyug8ICW5rOoSz kDk2yeoncYVLDijynsh5Zonnn9Q=; b=rfs0G39+vTIFjJRytbcqhLP2nkDWq/HD NsOkZp9JmSnPGR8ln4t4CGDsxvu3RztLRCG/YqOjrcJGXb0sp0osmLlMh5UVS5aq ug2hPFfN1vsuwZXf2tKDYm3hdwotza4bn0jHNJr6+9lVpK2N8WlGYMOTxrfodLZ0 +FIiCmpxjSc=
In-reply-to: <20110726233246.GA8168@fujiko>
References: <20110726233246.GA8168@fujiko>
On 2011.07.27 at 01:32 +0200, Francesco Allertsen wrote:
> Hi all,
>  I have tried to compile the latest -git today and I got the following
> error while compiling the xfs filesystem.
> 
>   CC      fs/xfs/linux-2.6/xfs_iops.o
>   fs/xfs/linux-2.6/xfs_iops.c:1025:14: error: 'xfs_get_acl' undeclared here 
> (not in a function)
> 
> I have bisected the problem and the first bad commit is this one
> 
>   commit 4e34e719e457f2e031297175410fc0bd4016a085
>   Author: Christoph Hellwig <hch@xxxxxx>
>   Date:   Sat Jul 23 17:37:31 2011 +0200
> 
>   fs: take the ACL checks to common code
> 
>   Replace the ->check_acl method with a ->get_acl method that simply reads an
>   ACL from disk after having a cache miss.  This means we can replace the ACL
>   checking boilerplate code with a single implementation in namei.c.
> 
>   Signed-off-by: Christoph Hellwig <hch@xxxxxx>
>   Signed-off-by: Al Viro <viro@xxxxxxxxxxxxxxxxxx>
> 
> Could you please solve this problem?  I have attached also the .config
> file if you need it.

It's already solved:  http://lkml.org/lkml/2011/7/26/94
But somehow Linus didn't notice this patch yet.

-- 
Markus

<Prev in Thread] Current Thread [Next in Thread>