[Top] [All Lists]

Re: [PATCH XFSPROGS 1/3] configure.in: Declare a requirement for at leas

To: "Theodore Ts'o" <tytso@xxxxxxx>
Subject: Re: [PATCH XFSPROGS 1/3] configure.in: Declare a requirement for at least autoconf 2.50
From: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date: Fri, 22 Jul 2011 10:28:50 -0400
Cc: Ext4 Developers List <linux-ext4@xxxxxxxxxxxxxxx>, xfs@xxxxxxxxxxx
In-reply-to: <1311292237-4155-1-git-send-email-tytso@xxxxxxx>
References: <1311292237-4155-1-git-send-email-tytso@xxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Thu, Jul 21, 2011 at 07:50:35PM -0400, Theodore Ts'o wrote:
> On Debian/Ubuntu systems, if autoconf version 2.13 is installed,
> autoconf will try to automatically figure out whether autoconf 2.13 or
> something more modern is required (since the autoconf maintainers,
> curses be upon them, didn't bother to maintain compatibility between
> autoconf 2.13 and 2.50).  Unfortunately, the hueristics aren't
> perfect, and although the configure.in file looks superficially like
> it will be compatible with autoconf 2.13, it isn't.  You will end up
> with a number of very subtle compilation failures if you use autoconf
> 2.13.
> So declare a requirement for autoconf 2.50 using AC_PREREQ(2.50).

Thanks a lot, I've applied our xfsprogs and xfstests patches, and also
ported the change to the xfsdump and dmapi repositories.

<Prev in Thread] Current Thread [Next in Thread>