xfs
[Top] [All Lists]

[PATCH XFSPROGS 1/3] configure.in: Declare a requirement for at least au

To: Ext4 Developers List <linux-ext4@xxxxxxxxxxxxxxx>, xfs@xxxxxxxxxxx
Subject: [PATCH XFSPROGS 1/3] configure.in: Declare a requirement for at least autoconf 2.50
From: "Theodore Ts'o" <tytso@xxxxxxx>
Date: Thu, 21 Jul 2011 19:50:35 -0400
Cc: "Theodore Ts'o" <tytso@xxxxxxx>
On Debian/Ubuntu systems, if autoconf version 2.13 is installed,
autoconf will try to automatically figure out whether autoconf 2.13 or
something more modern is required (since the autoconf maintainers,
curses be upon them, didn't bother to maintain compatibility between
autoconf 2.13 and 2.50).  Unfortunately, the hueristics aren't
perfect, and although the configure.in file looks superficially like
it will be compatible with autoconf 2.13, it isn't.  You will end up
with a number of very subtle compilation failures if you use autoconf
2.13.

So declare a requirement for autoconf 2.50 using AC_PREREQ(2.50).

Signed-off-by: "Theodore Ts'o" <tytso@xxxxxxx>
---
 configure.in |    1 +
 1 files changed, 1 insertions(+), 0 deletions(-)

diff --git a/configure.in b/configure.in
index 10c4c61..664c0e9 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,5 @@
 AC_INIT(include/libxfs.h)
+AC_PREREQ(2.50)
 AC_CONFIG_AUX_DIR([.])
 AC_CONFIG_MACRO_DIR([m4])
 AC_CONFIG_HEADER(include/platform_defs.h)
-- 
1.7.4.1.22.gec8e1.dirty

<Prev in Thread] Current Thread [Next in Thread>