xfs
[Top] [All Lists]

Re: [PATCH 1/1] Fix the ltp Makefile to allow for installation of all no

To: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Subject: Re: [PATCH 1/1] Fix the ltp Makefile to allow for installation of all non-c (scripts) files
From: Alex Elder <aelder@xxxxxxx>
Date: Wed, 13 Jul 2011 13:26:04 -0500
Cc: <alal@xxxxxxxxxx>, <xfs@xxxxxxxxxxx>
In-reply-to: <20110713121320.GA28126@xxxxxxxxxxxxx>
References: <CAP57jx5TWxwaDhp6yY+b_tBb8_WTBaRPDCfdQ3pV4Bs-S869QQ@xxxxxxxxxxxxxx> <20110713121320.GA28126@xxxxxxxxxxxxx>
Reply-to: <aelder@xxxxxxx>
On Wed, 2011-07-13 at 08:13 -0400, Christoph Hellwig wrote:
> On Fri, Jul 01, 2011 at 01:52:43PM -0700, Akshay Lal wrote:
> > Current the Makefile only builds the .c files and installs
> > them in the $INSTALL path. However, the ltp directory contains a shell 
> > script,
> > which doen't get copied over (installed) when a "make install"is invoked.
> > 
> > This behaviour causes test 080 to fail since it requires rwtest.sh to be
> > present in the ltp/ directory.
> > 
> > Tested: Updated the Makefile and ran a static build script & test
> > 080.
> 
> Thanks, applied.  (after fixing up mailer induced whitespace issues)

I see that test 80 is not part of the "auto" group.  Anyone
know why not?  I'm not even sure what it does; it may just
be unnecessary because it duplicates what other tests do.

But it's really quick (under 10 seconds even without speedy
hardware) so I don't see any harm to adding it to "auto" as
well as "quick".

Any thoughts?

                                        -Alex

<Prev in Thread] Current Thread [Next in Thread>