xfs
[Top] [All Lists]

Re: xfs_repair stuck?

To: xfs@xxxxxxxxxxx
Subject: Re: xfs_repair stuck?
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Mon, 11 Jul 2011 10:20:14 +1000
In-reply-to: <20110710155437.GA19200@xxxxxxxxxx>
References: <20110710155437.GA19200@xxxxxxxxxx>
User-agent: Mutt/1.5.20 (2009-06-14)
On Sun, Jul 10, 2011 at 05:54:37PM +0200, Louis-David Mitterrand wrote:
> Hi,
> 
> I've lauched xfs_repair on pretty damaged 300G partition and it has been
> stuck for a couple hours at this stage:
> 
>       bad magic # 0xdbe565b2 in inobt block 19/6115
>       expected level 1 got 34602 in inobt block 19/6115
>       agi_count 24064, counted 0 in ag 19
>       agi_freecount 1375, counted 0 in ag 19
>       agi unlinked bucket 0 is 44810432 in ag 19 (inode=2594947264)
>       agi unlinked bucket 11 is 44722251 in ag 19 (inode=2594859083)
>       agi unlinked bucket 24 is 44811800 in ag 19 (inode=2594948632)
>       agi unlinked bucket 32 is 44722400 in ag 19 (inode=2594859232)
>       agi unlinked bucket 47 is 65583 in ag 19 (inode=2550202415)
>       agi unlinked bucket 48 is 44811056 in ag 19 (inode=2594947888)
>       agi unlinked bucket 57 is 45920825 in ag 19 (inode=2596057657)
> 
> I tried interrupting and re-launching but it always stops here.

man xfs_repair:

       -P     Disable  prefetching  of  inode  and  directory
              blocks. Use this option if you find xfs_repair gets
              stuck and stops proceeding. Interrupting a stuck
              xfs_repair is safe.

Cheers,

Dave.
-- 
Dave Chinner
david@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>