[Top] [All Lists]

Re: [PATCH 26/27] xfs: cleanup I/O-related buffer flags

To: Alex Elder <aelder@xxxxxxx>
Subject: Re: [PATCH 26/27] xfs: cleanup I/O-related buffer flags
From: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date: Wed, 6 Jul 2011 05:11:54 -0400
Cc: Christoph Hellwig <hch@xxxxxxxxxxxxx>, xfs@xxxxxxxxxxx
In-reply-to: <1309925355.3381.55.camel@doink>
References: <20110701094321.936534538@xxxxxxxxxxxxxxxxxxxxxx> <20110701094607.536262104@xxxxxxxxxxxxxxxxxxxxxx> <1309925355.3381.55.camel@doink>
User-agent: Mutt/1.5.21 (2010-09-15)
On Tue, Jul 05, 2011 at 11:09:15PM -0500, Alex Elder wrote:
> On Fri, 2011-07-01 at 05:43 -0400, Christoph Hellwig wrote:
> > Remove the unused and misnamed _XBF_RUN_QUEUES flag, rename XBF_LOG_BUFFER
> > to the more fitting XBF_SYNCIO, and split XBF_ORDERED into XBF_FUA and
> > XBF_FLUSH to allow more fine grained control over the bio flags.  Also
> > cleanup processing of the flags in _xfs_buf_ioapply to make more sense,
> > and renumber the sparse flag number space to group flags by purpose.
> > 
> > Signed-off-by: Christoph Hellwig <hch@xxxxxx>
> Interesting that _XBF_RUN_QUEUES was never actually used.
> The new names are much more understandable.  Looks like
> READ_META and WRITE_META are now effectively gone...

They have been gone for a while.

<Prev in Thread] Current Thread [Next in Thread>