xfs
[Top] [All Lists]

[PATCH]: [xfstests] v2: Make ext2 requirement explicit for test 049

To: XFS Mailing List <xfs@xxxxxxxxxxx>
Subject: [PATCH]: [xfstests] v2: Make ext2 requirement explicit for test 049
From: Chandra Seetharaman <sekharan@xxxxxxxxxx>
Date: Fri, 10 Jun 2011 13:27:48 -0700
Cc: Eric Sandeen <sandeen@xxxxxxxxxx>
Organization: IBM
Reply-to: sekharan@xxxxxxxxxx
Test 049 depends on ext2 module being supported by the kernel.

This patch makes it a explicit, instead of failing the test with
obscure message.

Signed-Off-By: Chandra Seetharaman <sekharan@xxxxxxxxxx>
---

diff --git a/049 b/049
index 3d3f030..c6c4faa 100755
--- a/049
+++ b/049
@@ -64,6 +64,7 @@ _require_nobigloopfs
 _require_nonexternal
 _require_scratch
 _require_loop
+_require_ext2
 
 rm -f $seq.full
 
diff --git a/common.rc b/common.rc
index c510c66..44c746d 100644
--- a/common.rc
+++ b/common.rc
@@ -769,6 +769,24 @@ _require_loop()
     fi
 }
 
+# this test requires ext2 filesystem support
+#
+_require_ext2()
+{
+    if [ "$HOSTOS" != "Linux" ]
+    then
+       _notrun "This test requires linux for ext2 filesystem support"
+    fi
+
+    modprobe ext2 >/dev/null 2>&1
+    if grep ext2 /proc/filesystems >/dev/null 2>&1
+    then
+       :
+    else
+       _notrun "This test requires ext2 filesystem support"
+    fi
+}
+
 # this test requires that (large) loopback device files are not in use
 #
 _require_nobigloopfs()


<Prev in Thread] Current Thread [Next in Thread>