xfs
[Top] [All Lists]

Re: xfstests: device busy when umount

To: Amir Goldstein <amir73il@xxxxxxxxx>
Subject: Re: xfstests: device busy when umount
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Wed, 18 May 2011 16:31:53 +1000
Cc: Eric Sandeen <sandeen@xxxxxxxxxx>, Yongqiang Yang <xiaoqiangnk@xxxxxxxxx>, Ext4 Developers List <linux-ext4@xxxxxxxxxxxxxxx>, xfs-oss <xfs@xxxxxxxxxxx>
In-reply-to: <BANLkTi=pZS6sTjS61UmpbOsj+vF+ithVvw@xxxxxxxxxxxxxx>
References: <BANLkTimQW+kyqjmzpAHH_W5x2v1EWW2AZA@xxxxxxxxxxxxxx> <4DD286E5.8090105@xxxxxxxxxx> <BANLkTi=pZS6sTjS61UmpbOsj+vF+ithVvw@xxxxxxxxxxxxxx>
User-agent: Mutt/1.5.20 (2009-06-14)
On Tue, May 17, 2011 at 06:01:14PM +0300, Amir Goldstein wrote:
> On Tue, May 17, 2011 at 5:32 PM, Eric Sandeen <sandeen@xxxxxxxxxx> wrote:
> > On 5/17/11 4:03 AM, Yongqiang Yang wrote:
> >> Hi,
> >>
> >> I noticed that all tests which contain 'device busy' errors have
> >> falloc operations.  Does the error have something to do with falloc?

<shrug>

Perhaps a bit more detail about what you are testing, how you've set
up xfstests, etc, and some analysis of the problem is in order first?

> > cc'ing xfs list since xfs devs maintain xfstests.
> >
> > What tests have "device busy" errors?  What do the usual investigative
> > steps such as "lsof" and "fuser" tell you when this happens?
> 
> I tried running lsof | grep $TEST_DIR before umount
> and I tried sleep 1 before umount and it didn't yield anything.

Which usually indicates that you've got some kind of reference
counting problem preventing the filesystem from being unmounted.

> > Are there loop devices that didn't get cleaned up, or processes that
> > have not terminated?
> >
> > What tests have these problems?
> 
> for me 124 always fails to umount, and 198 and 213 sometimes fails to umount.

What, exactly, are you testing on? test 124 uses XFS_IOC_RESVSP
directly, not fallocate(), so all it is doing on a non-XFS
filesystem is iterating a loop that writes a 1MB file, reads it back
then unlinks it....

Cheers,

Dave.
-- 
Dave Chinner
david@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>