xfs
[Top] [All Lists]

Re: XFS_WANT_CORRUPTED_GOTO on repair of large myisam (mysql) table

To: "Matthew J. Probst" <mprobst@xxxxxxxxxxxxxxxxx>
Subject: Re: XFS_WANT_CORRUPTED_GOTO on repair of large myisam (mysql) table
From: Eric Sandeen <sandeen@xxxxxxxxxxx>
Date: Sun, 15 May 2011 22:29:13 -0500
Cc: xfs@xxxxxxxxxxx
In-reply-to: <4DD097F9.6070205@xxxxxxxxxxxxxxxxx>
References: <4DD097F9.6070205@xxxxxxxxxxxxxxxxx>
User-agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.17) Gecko/20110414 Thunderbird/3.1.10
On 5/15/11 10:20 PM, Matthew J. Probst wrote:
> ##########################
> Software:
> ##########################
> xfs on lvm2 on dm-multipath
> 
> Kernel: 2.6.18-238.9.1.el5 (from RH/Centos 5.6)
> kmod-xfs version 0.4-2

Please try removing kmod-xfs; that is an extremely old xfs codebase.

the kernel above comes with xfs.ko already an is much more up to date.
When kmod-xfs is installed, it overrides  the one shipped with the kernel.

Hopefully you'll have better luck with the newer code.

-Eric

> xfsprogs version 2.9.4-1
> lvm2 version: 2.02.74-5
> device mapper multipath verson: 0.4.7-42
> Mysql version 5.1 56

<Prev in Thread] Current Thread [Next in Thread>