xfs
[Top] [All Lists]

Re: XFS errors... can't repair them

To: Eric Sandeen <sandeen@xxxxxxxxxxx>
Subject: Re: XFS errors... can't repair them
From: Martín Marqués <martin.marques@xxxxxxxxx>
Date: Mon, 21 Feb 2011 19:56:02 -0300
Cc: xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:in-reply-to:references:date :message-id:subject:from:to:cc:content-type :content-transfer-encoding; bh=cSUZCZqEEcPCyiQnKR1RDYa+utIq6xwiC6gX3U1bYpQ=; b=NQOGx+ItHsvfhb7HO12HpuEuwCbjzxH1GJFbynrzy0X8eJkIPoO3HuJmNNwaXD7Tr3 ScWRpzWN4f03KwCGtjzRnrtfEAqkXg6AYbPwHjSHmV5wQK8TPyS7CAVH5VSjdxqfn8Df soneTJZ+H3ofHQbTH314t6ohVBIjQIns4puuM=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=B9kYmj80RSjQHi/07LpMaTDU3eme45BvyiEkXDQWLx5FWnYFc60Qbny2y6DVxuy+8e 7on0IdV/vufcTkxoPOZslI5rScrH61SEETfl3k4N2RWS57R87cMU4TIo6DggWBQ/vb/8 JfygG/vCp9umXTETLcOEpfabzC8ruesbbY2G8=
In-reply-to: <4D62A8AD.1060202@xxxxxxxxxxx>
References: <AANLkTik-ds_7kb62KTtrmuKewt1QN-JU1yfZhurx+sTj@xxxxxxxxxxxxxx> <4D62A8AD.1060202@xxxxxxxxxxx>
OK, for some strange reason this morning xfs_repair and xfs_check just
didn't do anything (froze on the console).

This afternoon I tried to see if I could try something out, and found
that all of a sudden xfs_repair was giving me output. -L cleared the
log and after that I was able to mount the FS without a lose.

Don't know why it didn't work today at work. Maybe it was because
today we lost (went to work at HP) our head of security. :-)

El día 21 de febrero de 2011 15:02, Eric Sandeen <sandeen@xxxxxxxxxxx> escribió:
> On 2/21/11 9:30 AM, Martín Marqués wrote:
>> I have a system with /home in XFS format. Just today I tried to copy a
>> big file, not knowing that there was little space left in the device.
>>
>> The thing is that when the FS got filled up, the system didn't let me
>> access /home anymore (not even as root). I rebooted and tried to use
>> xfs_check and xfs_repair, with no luck (it looks as if they do
>> nothing).
>
> Showing us the output would help....
>
> Use xfs_repair, not xfs_check.  If you want check-only, use xfs_repair -n.
>
>> The other FS on the same disk work OK. Just /home is giving me
>> problems. This is not on a RAID or a LVM.
>>
>> BTW, no reboot /home doesn't get mounted printing a lot of error messages:
>>
>> Feb 21 10:57:02 dagobah kernel: XFS mounting filesystem sda3
>> Feb 21 10:57:02 dagobah kernel: Starting XFS recovery on filesystem:
>> sda3 (logdev: internal)
>> Feb 21 10:57:04 dagobah kernel: XFS internal error
>> XFS_WANT_CORRUPTED_GOTO at line 1652 of file fs/xfs/xfs_alloc.c.
>> Caller 0xffffffffa0fc1e6c
>
> Looks like a corrupted or at least unreplayable log.  Did the box lose
> power prior to this?
>
> Repair won't replay a dirty log, and the only way to clear the log is to
> mount it.  If mounting fails, you may have to use xfs_repair -L to
> zero out the log, then do the repair.
>
>> Feb 21 10:57:04 dagobah kernel: Pid: 1618, comm: mount Tainted: P
>>      2.6.34.7-66.fc13.x86_64 #1
>
>
> -Eric
>



-- 
Martín Marqués
select 'martin.marques' || '@' || 'gmail.com'
DBA, Programador, Administrador

<Prev in Thread] Current Thread [Next in Thread>