xfs
[Top] [All Lists]

Re: XFS errors... can't repair them

To: Martín Marqués <martin.marques@xxxxxxxxx>
Subject: Re: XFS errors... can't repair them
From: Eric Sandeen <sandeen@xxxxxxxxxxx>
Date: Mon, 21 Feb 2011 12:02:21 -0600
Cc: xfs@xxxxxxxxxxx
In-reply-to: <AANLkTik-ds_7kb62KTtrmuKewt1QN-JU1yfZhurx+sTj@xxxxxxxxxxxxxx>
References: <AANLkTik-ds_7kb62KTtrmuKewt1QN-JU1yfZhurx+sTj@xxxxxxxxxxxxxx>
User-agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7
On 2/21/11 9:30 AM, Martín Marqués wrote:
> I have a system with /home in XFS format. Just today I tried to copy a
> big file, not knowing that there was little space left in the device.
> 
> The thing is that when the FS got filled up, the system didn't let me
> access /home anymore (not even as root). I rebooted and tried to use
> xfs_check and xfs_repair, with no luck (it looks as if they do
> nothing).

Showing us the output would help....

Use xfs_repair, not xfs_check.  If you want check-only, use xfs_repair -n.

> The other FS on the same disk work OK. Just /home is giving me
> problems. This is not on a RAID or a LVM.
> 
> BTW, no reboot /home doesn't get mounted printing a lot of error messages:
> 
> Feb 21 10:57:02 dagobah kernel: XFS mounting filesystem sda3
> Feb 21 10:57:02 dagobah kernel: Starting XFS recovery on filesystem:
> sda3 (logdev: internal)
> Feb 21 10:57:04 dagobah kernel: XFS internal error
> XFS_WANT_CORRUPTED_GOTO at line 1652 of file fs/xfs/xfs_alloc.c.
> Caller 0xffffffffa0fc1e6c

Looks like a corrupted or at least unreplayable log.  Did the box lose
power prior to this?

Repair won't replay a dirty log, and the only way to clear the log is to
mount it.  If mounting fails, you may have to use xfs_repair -L to
zero out the log, then do the repair.

> Feb 21 10:57:04 dagobah kernel: Pid: 1618, comm: mount Tainted: P
>      2.6.34.7-66.fc13.x86_64 #1


-Eric

<Prev in Thread] Current Thread [Next in Thread>