xfs
[Top] [All Lists]

Re: able to mount a fs, unable to repair it

To: Emmanuel Florac <eflorac@xxxxxxxxxxxxxx>
Subject: Re: able to mount a fs, unable to repair it
From: laurent+xfs@xxxxxxxxxxxxx
Date: Thu, 23 Dec 2010 20:34:41 +0100
Cc: xfs@xxxxxxxxxxx
In-reply-to: <20101223183531.19464601@xxxxxxxxxxxxxx> (Emmanuel Florac's message of "Thu, 23 Dec 2010 18:35:31 +0100")
References: <87r5d9uuez.fsf@xxxxxxxxxxxxxxxxxx> <20101223183531.19464601@xxxxxxxxxxxxxx>
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1 (gnu/linux)
Emmanuel Florac <eflorac@xxxxxxxxxxxxxx> writes:

Bonsoir Emmanuel,

> Le Thu, 23 Dec 2010 02:53:08 +0100 vous écriviez:
>
>> For a reason all my xfs FS got corrupted at the same time.
>> My setup is: xen host using lvm on top of soft raid6 on top of jbod
>> 3ware connected sata disks.
>> Both the host and the VM fs got corrupted.
>
> RAID-6 is extremely stable on the 3Ware, while software RAID-6 is
> dubbed experimental in the kernel. Software RAID can provide seducely
> high performance when running benchmarks, but IMO it doesn't fly when
> you need your CPU to do some other jobs, like running NFS daemons or
> even worse, VMs. Under high CPU loads concurrently coming from the
> software RAID and virtualisation stack, so many things may go
> wrong...

I can't agree more, I'm using both nfs AND VMs :)
It is very slow and very cpu consuming.
I'm moving away from xen to lxc on this home server, pretty sure it
will help.

> My advice : software RAID stinks under high CPU load/ high IO. Use
> hardware RAID whenever possible because it provides more predictable
> performance and remove many weird software interactions from the
> picture.

The 3w9550sx doesn't raid6, but I admit I've been thinking of using
its raid5 instead of the slow soft raid6.

Thanks for your advices :)

-- 
Laurent

<Prev in Thread] Current Thread [Next in Thread>