xfs
[Top] [All Lists]

Re: no rw xfs file systems in mtab: /proc/mounts

To: Eric Sandeen <sandeen@xxxxxxxxxxx>
Subject: Re: no rw xfs file systems in mtab: /proc/mounts
From: Honza Fikar <j.fikar@xxxxxxxxx>
Date: Thu, 23 Dec 2010 18:18:15 +0100
Cc: xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:message-id:date:from:reply-to :user-agent:mime-version:to:cc:subject:references:in-reply-to :x-enigmail-version:content-type; bh=zmgWpXjzSQ0MqO6HEQ5PUF4MlWqAuYr/GOAaHDrIo+E=; b=gzcuF7dv4+qicpGdD/OL61pin5apJGA1LXnLnZyq3QvAt49I77i1oprS+sYOVYsq6K gWMHHQ386WkllhQ9+prtxKkFd0nS8s4BuetTjSQSI7IllG9Eq8Z2pzBGdI0HvsXnb0eQ dWEkYqtv7Z1/PFUsnwbNipD1tzjnJ7laMuhWM=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:reply-to:user-agent:mime-version:to:cc:subject :references:in-reply-to:x-enigmail-version:content-type; b=KfVDjRpEvO+NbrFyigfeQqt3WsXHVIp8zyx8iRczWoK239XlYdro0Y63AxZnZ77/93 nf8HGB/90YXOu/o3ag11dVuJn14f7/9sULJYAXZ4L+Zi1PFHlKxXnpXibbMOVtTYdju5 aY74FXGdUrWQ1LeEr7ebAYrjtqFifeXVeH2WY=
In-reply-to: <4D13648B.8000105@xxxxxxxxxxx>
References: <AANLkTi=Xes02L3XfZvUu6Yh2yi2FR8GtpVdOGzngVjJk@xxxxxxxxxxxxxx> <4D13648B.8000105@xxxxxxxxxxx>
Reply-to: j.fikar@xxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13) Gecko/20101222 Lightning/1.0b3pre Thunderbird/3.1.7
> hm that's a little confusing, what it means is it looked
> in /proc/mounts and did not find anything, or so it thought.

I agree that it's confusing, while there are xfs mounted rw in /proc/mounts

> As a result of:
> 
> 89e4b5bd5615edc584a5111c86f12b4f89f8dd7d xfs_fsr: use /proc/mounts if 
> available

I "quickly and dirty" tried to use /etc/mtab instead, but the result is
the same. Even tried some old version (3.0.3), which uses mtab and it's
the same.


> What does your /proc/mounts show?

it shows the lines included in the original e-mail, just here it is
wrapped, i.e. for the not working case:

>> ...
>> /dev/mapper/root / xfs
>> rw,noatime,attr2,inode64,logbufs=8,logbsize=256k,noquota 0 0
>> ...

and for working case:

>> ...
>> /dev/root / xfs
>> rw,noatime,attr2,delaylog,inode64,logbufs=8,logbsize=256k,noquota 0 0
>> /dev/mapper/encrypted /home xfs
>> rw,noatime,attr2,delaylog,inode64,logbufs=8,logbsize=256k,sunit=512,swidth=1536,noquota
>> 0 0
>> ...

Honza

Attachment: signature.asc
Description: OpenPGP digital signature

<Prev in Thread] Current Thread [Next in Thread>