xfs
[Top] [All Lists]

able to mount a fs, unable to repair it

To: xfs@xxxxxxxxxxx
Subject: able to mount a fs, unable to repair it
From: laurent+xfs@xxxxxxxxxxxxx
Date: Thu, 23 Dec 2010 02:53:08 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1 (gnu/linux)
Hi !

For a reason all my xfs FS got corrupted at the same time.
My setup is: xen host using lvm on top of soft raid6 on top of jbod
3ware connected sata disks.
Both the host and the VM fs got corrupted.

ATM host is using 2.6.32 (debian/squeeze), xfsprogs are 3.1.4

I've had 2 kinds of corruptions:
1) unable to mount the FS, been able to xfs_repair -L
2) able to mount the FS, xfs_check was reporting errors, unable to
xfs_repair the fs

For most of the FS, i've managed to either mkfs.xfs or xfs_repair then
rsync from the backup.

I'm left with my 1.5TB fs for which i also have a full backup, i'm
able to mount it (no kernel error or anything when
mounting it). xfs_check on this unmounted FS gives errors. xfs_repair
(after a long long time) is unable to find a suitable thingie to
repair the FS.

https://gist.github.com/752411 xfs_{db,check,repair,metadump} results.
(haven't checked the memory/disk usage when doing the metadump)

I can't really tell why all this happened in the first place.
Been having power supply issues some weeks ago, been upgrading from
lenny to squeeze, been playing with xen & lxc at the same, been doing
my xmas shopping a bit late ! :-)

I'd be curious to know how to repair the 1.5TB FS, any idea on what i
could do ?

TIA

-- 
Laurent

<Prev in Thread] Current Thread [Next in Thread>