xfs
[Top] [All Lists]

Re: Anyone using XFS in production on > 20TiB volumes?

To: Emmanuel Florac <eflorac@xxxxxxxxxxxxxx>
Subject: Re: Anyone using XFS in production on > 20TiB volumes?
From: Justin Piszcz <jpiszcz@xxxxxxxxxxxxxxx>
Date: Wed, 22 Dec 2010 19:28:29 -0500 (EST)
Cc: Eric Sandeen <sandeen@xxxxxxxxxxx>, xfs@xxxxxxxxxxx
In-reply-to: <20101223012655.2681c596@xxxxxxxxxxxxxx>
References: <alpine.DEB.2.00.1012221128440.5245@xxxxxxxxxxxxxxxx> <20101222175611.1c7d5190@xxxxxxxxxxxxxxxxxxxx> <4D124B71.9030401@xxxxxxxxxxx> <20101223012655.2681c596@xxxxxxxxxxxxxx>
User-agent: Alpine 2.00 (DEB 1167 2008-08-23)


On Thu, 23 Dec 2010, Emmanuel Florac wrote:

Le Wed, 22 Dec 2010 13:03:13 -0600 vous écriviez:

http://xfs.org/index.php/XFS_FAQ#Q:_I_want_to_tune_my_XFS_filesystems_for_.3Csomething.3E

which mentions getting your geometry right if it's hardware raid
that can't be detected automatically.

Just as a side note : I tried several times to manually set the
filesystem layout to precisely match the underlying hardware RAID
with sunit and swidth but didn't find that it made a noticeable
difference. On my 39.9 TB systems, the default agcount is 39, while the
optimum would be (theorically at least)  42.

--
------------------------------------------------------------------------
Emmanuel Florac     |   Direction technique
                   |   Intellique
                   |    <eflorac@xxxxxxxxxxxxxx>
                   |   +33 1 78 94 84 02
------------------------------------------------------------------------


Hi, I concur, for hardware raid (at least on 3ware cards) I have found it makes no difference, thanks for confirming.

Which RAID cards did you use?

Justin.
<Prev in Thread] Current Thread [Next in Thread>