xfs
[Top] [All Lists]

Re: xfs_efi_item slab leak

To: Nick Piggin <npiggin@xxxxxxxxx>
Subject: Re: xfs_efi_item slab leak
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Sat, 18 Dec 2010 11:02:45 +1100
Cc: xfs@xxxxxxxxxxx
In-reply-to: <AANLkTi=LrU2CsC-VZmJ5M9U7eJpjqfAv8UgaEYv=Sg01@xxxxxxxxxxxxxx>
References: <AANLkTi=LrU2CsC-VZmJ5M9U7eJpjqfAv8UgaEYv=Sg01@xxxxxxxxxxxxxx>
User-agent: Mutt/1.5.20 (2009-06-14)
On Sat, Dec 18, 2010 at 05:04:40AM +1100, Nick Piggin wrote:
> After running xfstests and then unmounting and rmmodding xfs, I get this bug
> 
> [ 3473.194517] 
> =============================================================================
> [ 3473.194697] BUG xfs_efi_item: Objects remaining on kmem_cache_close()
> [ 3473.194793] 
> -----------------------------------------------------------------------------
> [ 3473.194794]
> [ 3473.195056] INFO: Slab 0xffffea0006ad5e00 objects=35 used=2
> fp=0xffff8801e8640e80 flags=0xc000000000004080
> [ 3473.195201] Pid: 22011, comm: rmmod Not tainted 2.6.37-rc6+ #116
> [ 3473.195201] Call Trace:
> [ 3473.195201]  [<ffffffff8110bcf1>] slab_err+0x91/0xa0
> [ 3473.195201]  [<ffffffff8110f088>] ? __slab_alloc+0x138/0x480
> [ 3473.195201]  [<ffffffff8108081d>] ? trace_hardirqs_off+0xd/0x10
> [ 3473.195201]  [<ffffffff811112a4>] ? kmem_cache_destroy+0x154/0x3e0
> [ 3473.195201]  [<ffffffff8108081d>] ? trace_hardirqs_off+0xd/0x10
> [ 3473.195201]  [<ffffffff811105a4>] ? __kmalloc+0x104/0x220
> [ 3473.195201]  [<ffffffff811112c7>] kmem_cache_destroy+0x177/0x3e0
> [ 3473.195201]  [<ffffffffa0086e47>] xfs_destroy_zones+0x37/0x100 [xfs]
> [ 3473.195201]  [<ffffffffa0088f88>] exit_xfs_fs+0x33/0x3d [xfs]
> [ 3473.195201]  [<ffffffff8109060a>] sys_delete_module+0x17a/0x270
> [ 3473.195201]  [<ffffffff8160340f>] ? lockdep_sys_exit_thunk+0x35/0x67
> [ 3473.195201]  [<ffffffff810030bb>] system_call_fastpath+0x16/0x1b
> [ 3473.195201] INFO: Object 0xffff8801e8640910 @offset=2320
> [ 3473.195201] INFO: Allocated in kmem_zone_alloc+0x8c/0xd0 [xfs]
> age=2263917 cpu=15 pid=4514
> [ 3473.195201] INFO: Freed in xfs_efi_item_free+0x19/0x30 [xfs]
> age=2263918 cpu=15 pid=4514
> [ 3473.195201] INFO: Object 0xffff8801e86427e0 @offset=10208
> [ 3473.195201] INFO: Allocated in kmem_zone_alloc+0x8c/0xd0 [xfs]
> age=2103034 cpu=15 pid=22329
> [ 3473.195201] INFO: Freed in xfs_efi_item_free+0x19/0x30 [xfs]
> age=2103034 cpu=15 pid=22329
> [ 3473.197616] SLUB xfs_efi_item: kmem_cache_destroy called for cache
> that still has objects.
> [ 3473.197794] Pid: 22011, comm: rmmod Not tainted 2.6.37-rc6+ #116
> [ 3473.197892] Call Trace:
> [ 3473.197980]  [<ffffffff811114a7>] kmem_cache_destroy+0x357/0x3e0
> [ 3473.198120]  [<ffffffffa0086e47>] xfs_destroy_zones+0x37/0x100 [xfs]
> [ 3473.198240]  [<ffffffffa0088f88>] exit_xfs_fs+0x33/0x3d [xfs]
> [ 3473.198337]  [<ffffffff8109060a>] sys_delete_module+0x17a/0x270
> [ 3473.198435]  [<ffffffff8160340f>] ? lockdep_sys_exit_thunk+0x35/0x67
> [ 3473.198534]  [<ffffffff810030bb>] system_call_fastpath+0x16/0x1b

Ok, after unmounting everything I can see two items in remaining in
the xfs_efi_item cache after an xfstests run. Іt's probably to do
with a filesystem shutdown not cleaning them up correctly. I'll put
it on my list of stuff to track down.

Cheers,

Dave.
-- 
Dave Chinner
david@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>