xfs
[Top] [All Lists]

[PATCH 1/2] xfsprogs: fix debian upgrade issue

To: xfs <xfs@xxxxxxxxxxx>
Subject: [PATCH 1/2] xfsprogs: fix debian upgrade issue
From: nathans@xxxxxxxxxx
Date: Tue, 9 Nov 2010 22:56:58 +1100 (EST)
In-reply-to: <1189766076.18791289303743211.JavaMail.root@xxxxxxxxxxxxxxxxxxxxxx>
Reply-to: Nathan Scott <nathans@xxxxxxxxxx>
Sender: nscott@xxxxxxxxxx
Fix xfs_estimate issue upgrading xfsprogs/xfsdump from lenny
    
Fix bug "xfsprogs: file conflict when upgrading from lenny":
add 'Replaces: xfsdump (<< 3.0.0); thanks to Vagrant Cascadian
for the analysis.
    
Signed-off-by: Gregor Herrman <gregoa@xxxxxxxxxx>
Reviewed-by: Nathan Scott <nathans@xxxxxxxxxx>

diff --git a/debian/control b/debian/control
index 652ffcb..f429434 100644
--- a/debian/control
+++ b/debian/control
@@ -12,6 +12,7 @@ Depends: ${shlibs:Depends}, ${misc:Depends}
 Provides: fsck-backend
 Suggests: xfsdump, acl, attr, quota
 Breaks: xfsdump (<< 3.0.0)
+Replaces: xfsdump (<< 3.0.0)
 Architecture: any
 Description: Utilities for managing the XFS filesystem
  A set of commands to use the XFS filesystem, including mkfs.xfs.

<Prev in Thread] Current Thread [Next in Thread>