xfs
[Top] [All Lists]

Re: [PATCH] xfstests: use a common _filter_test_dir function

To: Alex Elder <aelder@xxxxxxx>
Subject: Re: [PATCH] xfstests: use a common _filter_test_dir function
From: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date: Mon, 25 Oct 2010 09:45:43 -0400
Cc: xfs@xxxxxxxxxxx
In-reply-to: <201010221409.o9ME9OTQ003885@xxxxxxxxxxxxxxxxxxxxxx>
References: <201010221409.o9ME9OTQ003885@xxxxxxxxxxxxxxxxxxxxxx>
User-agent: Mutt/1.5.21 (2010-09-15)
On Fri, Oct 22, 2010 at 09:09:24AM -0500, Alex Elder wrote:
> Christoph Hellwig suggested that a function similar to the common
> "_filter_scratch" function ought to be created to handle filtering
> of the TEST_DIR and TEST_DEV variables.  This patch implements that.
> 
> The name "_filter_test" seems like it might suggest it does
> something different, so I'm calling this one "_filter_test_dir".
> This unfortunately makes the "test" and "scratch" functions have
> different naming conventions, but I guess we should be accustomed
> to that by now (consider "TEST_DIR" and "SCRATCH_MNT").
> 
> Signed-off-by: Alex Elder <aelder@xxxxxxx>

Looks good,

Reviewed-by: Christoph Hellwig <hch@xxxxxx>

<Prev in Thread] Current Thread [Next in Thread>