xfs
[Top] [All Lists]

Re: Question/Problem: Mounting of XFS filesystem takes a lot of time

To: Andreas Hasenkopf <andreas.hasenkopf@xxxxxxxxxxxxxxxxxxxxxxxx>
Subject: Re: Question/Problem: Mounting of XFS filesystem takes a lot of time
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Wed, 20 Oct 2010 10:08:11 +1100
Cc: xfs@xxxxxxxxxxx
In-reply-to: <1287521058.2000.21.camel@x200>
References: <1287521058.2000.21.camel@x200>
User-agent: Mutt/1.5.20 (2009-06-14)
On Tue, Oct 19, 2010 at 10:44:18PM +0200, Andreas Hasenkopf wrote:
> Hello,
> since today I have quite a big problem and I'd like to get some opinions
> from experts on how to proceed in solving the problem.
> 
> The Problem:
> Since today mounting and unmounting of any XFS partition on my system
> takes (depending on size of partition) up to 15 minutes and more.

How big is the journal? (xfs_info output will tell us).

> The system in its current configuration was working fine for over 6
> months and I did not change anything recently with respect of upgrades.
> 
> I have already tried booting a Linux-LiveCD and mounting the XFS
> partitions in that system: same result.
> Also I have run xfs_check and xfs_repair -n on the partitions on the
> RAID1 configuration: mounting still takes a lot of time (15 mins +).

Was it a clean unmount, or is it doing journal replay? 

If you do:

# mount <dev> <mtpt> ; umount <mtpt> ; time mount <dev> <mtpt>

Does the second mount take 15 minutes?

> And now to my question:
> Could my problem be a software related problem (Linux, XFS, something
> else) or should I consider hardware problems?

Sounds suspiciously like failing hardware to me. Any errors in
dmesg?

Cheers,

Dave.
-- 
Dave Chinner
david@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>