[Top] [All Lists]

Re: xfs_db -c frag -r /dev/sdb1 segmentation fault

To: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Subject: Re: xfs_db -c frag -r /dev/sdb1 segmentation fault
From: Robert Pipca <robertpipca@xxxxxxxxx>
Date: Mon, 4 Oct 2010 16:43:02 -0300
Cc: Dave Chinner <david@xxxxxxxxxxxxx>, xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:received:in-reply-to :references:date:message-id:subject:from:to:cc:content-type :content-transfer-encoding; bh=prTEUzF6LfsSvlUKAykAJuXtSrRfXgBiINzjypA1kNs=; b=TfzSgCHUAEbiVUA/CFBhKAhCWasINCZExkaE31t4jTmULamPEbuAUQ0MKmD8Gofw3T +q+GKRM1NXV5u4EJN8lDiH9LtLjJoPldNPDlmGeMgql0pjgLP59BbO5b0IwJF6zhgXUQ FqUIOq63+i9nKMQ286HINpT3fen85fpFP6j6k=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=xaWnbRD9x/XpVNCappTB+rHRJWIWm8xSZa1J5dAj02roTFkcaVg8cB4e+SCjbn2Wua r2oH7aXshpfejkuvFoBy3nUScwE84zzaPjzdJfmlVXYKw73hP4cT/0GuXBEzFxDUpA5U AQLPFdeq299nE+RDzxyhdQGIebopxgEiEXWwI=
In-reply-to: <20101003064547.GA9071@xxxxxxxxxxxxx>
References: <AANLkTi=kzGSGtmk8a_eu5n9w6wbvt_f28Va9gSeWNgCe@xxxxxxxxxxxxxx> <20101002103902.GE4681@dastard> <20101003064547.GA9071@xxxxxxxxxxxxx>

I ran it on a mounted filesystem.

It's a squid webcache machine, and I ran it on the HD that's doing the
cache, to see how fragmented it is....

This thing is: After I ran xfs_fsr on the same partition, xfs_db
started working again (even though both times I used "-r").

Should this have happened?


- Robert

2010/10/3 Christoph Hellwig <hch@xxxxxxxxxxxxx>:
> On Sat, Oct 02, 2010 at 08:39:03PM +1000, Dave Chinner wrote:
>> Note that the crash could be caused by a corrupted filesystem.
> Or running it on a mounted filesystem.  Robert, did you run the command
> on a mounted or unmounted filesystem?

<Prev in Thread] Current Thread [Next in Thread>