xfs
[Top] [All Lists]

xfs_repair never finishes on lvm partition

To: xfs@xxxxxxxxxxx
Subject: xfs_repair never finishes on lvm partition
From: Knowledge Seeker <knoseeker@xxxxxxxxxxxxxx>
Date: Mon, 4 Oct 2010 02:57:42 +0000
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=googlemail.com; s=gamma; h=domainkey-signature:mime-version:received:received:date:message-id :subject:from:to:content-type; bh=J0h1w8DjETLDET+onGOtU+giqJQnbkOXO5lb6aR5thY=; b=b841h1ysfJbxk4Gfm8Tr5M93qLp5kF5hMHXrhlEbbNIHXVJtG0BxGdfRNsRC8jcv4r TCdlXtITn05a3a6a7+3enDobrTI7jS4UHr4Jj80h68gxeAeuCAGQEMMs9tKLCRPFloXr 4cRhvMkJMrqqitWtt04YkQYRv5yJRIZ1Xp9Jg=
Domainkey-signature: a=rsa-sha1; c=nofws; d=googlemail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=ITnHdJoRYsvapQNmff4K1Q0q0nYdSz0HtdG4VqMlr9u7XWKKb/WSF7TqOl/d8xhPw8 IxLZKRri5JmXrL71KNSCaMWwlPDZzmjYrJfvwHyLI2w8Yl52RCi4G6UCGxTWKYx+oc6u p0V1CbREy8omAqxMRLa91RjeI9ErjNjQCvam4=
Hi,

I've sent the below message to the Debian Users list and they told me to send it here.

I'm using Debian Lenny box with 2 hds.

The first one is used by the OS and the second one is another system witch runs in virtual machine (Virtual Box).
This virtual machine also runs Debian Lenny.

The vm's hd has 2 fdisk partitions, one being LVM.

On the last week, due a power failure, there was a corruption in the file system of my home xfs partition inside the LVM.
When  I tried to access it, my OS answered that it's not a file or a directory.
Umounting and mounting again, the error persists.
I tried an xfs_check and it said to mount and umount the filesystem and if it does not work to run xfs_repair with -L.
I tried it a couple of times and it didn't work, so I ran xfs_repair -L /dev/mapper/storage-home

On Phase 6, it just freezes in:

bad hash table for directory inode 2147483859 (no data entry): rebuilding
rebuilding directory inode 2147483859

And never finish.
I let running for 2 days long.

When I use ps to see the state:

 2359 pts/0    Sl+    0:11 xfs_repair -L /dev/mapper/storage-home

Interruptible sleep (waiting for an event to complete), multi threaded, in foreground.

It just stoped when I sent an interrupt signal Ctrl+C.

I tried to do the same from the host machine (real machine), since the HD could be accessed from it.
The funniest thing is that the xfs_repair did not hang, but when I try to mount the partition it does not mount the  full partition.
An ls in the /mnt mounting /dev/storage/home (from host machine), doesn't show the /home, it shows a subdirectory from /home.
And if I start again the Virtual Machine, it prints the same error: /home is not file or directory.

Weird..


Extra information:
The versions:
# xfs_repair -V
xfs_repair version 2.9.8

#fstab entry
/dev/mapper/storage-home /home           xfs     defaults        0       2

Some one have any idea, how to solve it?

Thanks in advance

Regards

--
Knoseeker
<Prev in Thread] Current Thread [Next in Thread>