xfs
[Top] [All Lists]

Problem with file system on iSCSI FileIO

To: xfs@xxxxxxxxxxx
Subject: Problem with file system on iSCSI FileIO
From: Slawomir Nowakowski <slawomir.nowakowski@xxxxxxxxxx>
Date: Thu, 23 Sep 2010 15:35:02 +0200
Cc: "'Ryszard Stawiarski'" <ryszard.stawiarski@xxxxxxxxxx>, Łukasz Wittig <lukasz.wittig@xxxxxxxxxx>, Artur Piechocki <artur.piechocki@xxxxxxxxxx>
Organization: Open-E
Reply-to: slawomir.nowakowski@xxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.12) Gecko/20100915 Thunderbird/3.0.8
Dear Sir,

We are using iSCSI FileIO on the LVM. The file (called lun) has been initialized with:
dd if=/dev/zero of=/dev/vg+vg00/lv+i+lv0000 bs=1M conv=notrunc

on the XFS formatted logical volume.

Additionally, we use 2.6.27-39 kernel  and xfs-tools 2.10.1

After some time, without any additional errors, we are not able mount the volume. After mount command we get:


"mount: Structure needs cleaning"

in dmesg we can see:

"XFS: failed to read root inode"

If we run the xfs_repair, the lun file will be removed and all data on the iSCSI FileIO volume is lost.

I have found in the FAQ that this can be everything:

http://xfs.org/index.php/XFS_FAQ#Q:_I_see_applications_returning_error_990_or_.22Structure_needs_cleaning.22.2C_what_is_wrong.3F

But do you know if it is possible to recover the data somehow?

Thanks in advance for response

--

If you have any more questions, please do not hesitate to contact me.

Best Regards

Slawomir Nowakowski
Technical Support Engineer
-------------------------------------------------------
Open-E GmbH
e-mail: slawomir.nowakowski@xxxxxxxxxx
http://www.open-e.com/
-------------------------------------------------------

<Prev in Thread] Current Thread [Next in Thread>